Linuxdoc-tools-native do_install Failed

This forum is for users of Microchip MPUs and who are interested in using Linux OS.

Moderator: nferre

sephers2
Posts: 5
Joined: Mon Mar 05, 2018 12:28 am

Linuxdoc-tools-native do_install Failed

Mon Mar 05, 2018 12:46 am

Hi,

I'm currently trying to compile Yocto for use on the SAMA5D36-EK but I'm running into some errors. I'm at the stage of compiling Yocto, according to this page, with the command:

Code: Select all

bitbake -c populate_sdk atmel-qt5-demo-image
Originally I was getting the error:

Code: Select all

qmlbrowser-1.6-r1 do_fetch: Fetcher failure for URL: 'https://github.com/linux4sam/qml-browser/archive/master.tar.gz;downloadfilename=qml-browser-master.tar.gz'. Checksum mismatch!

File: '/home/george/yocto/poky/build-atmel/downloads/qml-browser-master.tar.gz' has md5 checksum 6842f59bbee379866a1706523592afeb when 899d34ceed7797360fe122253fd6d12d was expected
File: '/home/george/yocto/poky/build-atmel/downloads/qml-browser-master.tar.gz' has sha256 checksum e551459f7dabba30cb476bb6c46eaad451a96f65476ef32dabbf05102cdc0b23 when cd6b3cee307ef2154e188ade2013b5e33bd1107faa508cd40aa7bff20fd61d54 was expected

If this change is expected (e.g. you have upgraded to a new version without updating the checksums) then you can use these lines within the recipe:
SRC_URI[md5sum] = "6842f59bbee379866a1706523592afeb"
SRC_URI[sha256sum] = "e551459f7dabba30cb476bb6c46eaad451a96f65476ef32dabbf05102cdc0b23"

Otherwise you should retry the download and/or check with upstream to determine if the file has become corrupted or otherwise unexpectedly modified.
I did wget on the URL to ensure it wasn't my connection, but it downloaded fine so I adjusted the recipe accordingly (don't know if this was the correct thing to do or not), but I'm now getting the following error:

Code: Select all

ERROR: linuxdoc-tools-native-0.9.69-r0 do_install: oe_runmake failed
ERROR: linuxdoc-tools-native-0.9.69-r0 do_install: Function failed: do_install (log file is located at /home/george/yocto/poky/build-atmel/tmp/work/x86_64-linux/linuxdoc-tools-native/0.9.69-r0/temp/log.do_install.17861)
ERROR: Logfile of failure stored in: /home/george/yocto/poky/build-atmel/tmp/work/x86_64-linux/linuxdoc-tools-native/0.9.69-r0/temp/log.do_install.17861
I can post the full log but it's a bit long, however the error seems to be shown at the end:

Code: Select all

| -------- Building linuxdoc-tools docs ---------
| Installed tree: /home/george/yocto/poky/build-atmel/tmp/work/x86_64-linux/linuxdoc-tools-native/0.9.69-r0/image/home/george/yocto/poky/build-atmel/tmp/sysroots/x86_64-linux/usr
| Using temporary directory: /home/george/yocto/poky/build-atmel/tmp/work/x86_64-linux/linuxdoc-tools-native/0.9.69-r0/temp/ldt.cbQh5B9QSV
| - Building info docs
| Unescaped left brace in regex is illegal here in regex; marked by <-- HERE in m/\\nameurl{ <-- HERE (.*)}{(.*)}/ at /home/george/yocto/poky/build-atmel/tmp/work/x86_64-linux/linuxdoc-tools-native/0.9.69-r0/temp/ldt.cbQh5B9QSV/linuxdoc-tools/fmt/fmt_latex2e.pl line 287.
| Compilation failed in require at /home/george/yocto/poky/build-atmel/tmp/work/x86_64-linux/linuxdoc-tools-native/0.9.69-r0/temp/ldt.cbQh5B9QSV/linuxdoc-tools/LinuxDocTools.pm line 342.
| Makefile:90: recipe for target 'install' failed
| make: *** [install] Error 255
| WARNING: exit code 1 from a shell command.
| ERROR: Function failed: do_install (log file is located at /home/george/yocto/poky/build-atmel/tmp/work/x86_64-linux/linuxdoc-tools-native/0.9.69-r0/temp/log.do_install.17861)
ERROR: Task (/home/george/yocto/poky/meta/recipes-devtools/linuxdoc-tools/linuxdoc-tools-native_0.9.69.bb:do_install) failed with exit code '1'
I'm compiling on Ubuntu 17.10 have used the git branch v5.9.1 of meta-qt5 yocto git according to the following instructions.

Thanks in advance,

George
blue_z
Location: USA
Posts: 1721
Joined: Thu Apr 19, 2007 10:15 pm

Re: Linuxdoc-tools-native do_install Failed

Tue Mar 06, 2018 3:41 am

Unable to fully replicate the issues you encountered.
Got the same validation error with qml-browser-master.tar.gz, and made the kludge as suggested.
The build was then able to complete.
This was done today on an older 64-bit Lubuntu 14.04.2 host.
An x86 host built 5.7 about five months ago without any issues.

Regards
sephers2
Posts: 5
Joined: Mon Mar 05, 2018 12:28 am

Re: Linuxdoc-tools-native do_install Failed

Sat Mar 10, 2018 2:28 pm

I installed Ubuntu 16.04 and had no problems. I guess doing it on Ubuntu 17.10 was causing issues.

Cheers for your help.

Return to “LINUX”

Who is online

Users browsing this forum: No registered users and 0 guests