AT91SAM9263ek rev B, Samba and Dataflash

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

maddis
Posts: 35
Joined: Wed Apr 02, 2008 9:03 am

AT91SAM9263ek rev B, Samba and Dataflash

Thu Nov 13, 2008 2:26 pm

I'm not sure where this thread should be. I searched the forum and this might be best(?) place.

I have device on AT91SAM9263ek rev A that has been working just fine. Now I have new batch of those devices, but since rev A of silicon is no longer available rev B is used instead. That creates all sort of problems.

With Samba version 2.7 I was able to connect to RomBoot via RS232 and SDRAM init goes ok, but Dataflash and Nandflash are not initialized ok. That dataflash is more serious problem at the moment. RomBoot cannot detect the dataflash although it is the same one used in previous hardware version. I also checked and all the signals goes ok. But strange thing is that MOSI data is always zero. Line is driven to 3.3V when SPI communication is not active so it's not hardware failure.

I tapped to RS232 line an listened what goes on between PC and Atmel. It seems that PC send exactly the same data to both old and new version of hardware, but get's different responses.

I though this might be Samba problem so I installed Samba 2.8. Now the Samba won't even start! I checked the RS232-traffic and it seems Samba is trying to send something to device at start and then run it. I don't know if it works or not, but there are no windows showing for Samba. All I can see is process called samba taking about 50% of CPU.

I'm guessing this is silicon rev B related issue, but I'm not sure how to fix it?
maddis
Posts: 35
Joined: Wed Apr 02, 2008 9:03 am

Re: AT91SAM9263ek rev B, Samba and Dataflash

Mon Nov 17, 2008 9:03 am

Okay, I was able to get the sam-ba working with rev B silicone. It seems that rev B has a bug in SPI and SWRST - bit needs to be written twice in order to get wanted result. It's nice to know that what was once working is not anymore.

Still trying to get the bootstrap working, but I'm guessing the problems are related to that same thing.
kaveh_fd
Posts: 1
Joined: Tue Nov 25, 2008 7:31 pm

Re: AT91SAM9263ek rev B, Samba and Dataflash

Tue Nov 25, 2008 7:36 pm

Rev-B of SAM9263 requires that SPI reset command issues twice, check the errata section. That's why data flash communication fails.

I have a binary file received from Atmel that needs to be copied into LIB folder and makes it work, I have also attached this file to this message.
Attachments
isp-dataflash-at91sam9263.zip
Unzip the file and change the extension from .xxx to .bin. Copy the isp-dataflash-at91sam9263.bin file to c:\Program Files\ATMEL Corporation \AT91-ISP v1.11\SAM-BA v2.7\lib\AT91SAM9263-EK.
(4.73 KiB) Downloaded 44 times

Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 0 guests