[Closed] at91sam9m10g45-sd appears to crash after bootstrap

Discussion around AT91RM9200 and SAM9 Series Products.

Moderator: nferre

jmaxxz
Posts: 2
Joined: Mon Oct 08, 2018 9:57 pm

[Closed] at91sam9m10g45-sd appears to crash after bootstrap

Mon Oct 08, 2018 10:11 pm

I have been trying to get a at91sam9m10g45ek equivalent board to boot linux from sd card. To do this I've built an image using yocto and the meta-atmel project. To do this I've created and built for the below machine conf (at91sam9m10g45ek-sd.conf). When I attempt to boot the resulting image the board gets stuck in a reboot loop with at91bootstrapper failing to hand over to uboot. I fear I maybe a bit out of my depth so any suggestions would be greatly appreciated.


at91sam9m10g45ek-sd.conf

Code: Select all

#@TYPE: Machine
#@Name: at91sam9m10g45ek-sd
#@DESCRIPTION: at91sam9m10g45ek-sd board

require include/at91sam9.inc

MACHINE_FEATURES = "apm vfat ext4 usbhost usbgadget"
KERNEL_DEVICETREE = " at91sam9m10g45ek.dtb \
                     "

IMAGE_FSTYPES += " tar.gz wic"

do_image_wic[depends] += "u-boot-at91:do_deploy"
WKS_FILE = "sdimage-bootpart.wks"
IMAGE_BOOT_FILES = "BOOT.BIN u-boot.bin zImage \
  at91sam9m10g45ek.dtb \
  zImage-at91sam9m10g45ek.dtb \
  "
UBOOT_MACHINE = "at91sam9m10g45ek_mmc_defconfig"
UBOOT_ENTRYPOINT =  "0x70008000"
UBOOT_LOADADDRESS = "0x70008000"

# Needed for wic
EXTRA_IMAGEDEPENDS += "dosfstools-native mtools-native"

AT91BOOTSTRAP_LOAD = "sdboot-uboot"
AT91BOOTSTRAP_TARGET = "at91sam9m10g45eksd_uboot_defconfig"
AT91BOOTSTRAP_MACHINE = "at91sam9m10g45ek"
DTXD output:

Code: Select all

AT91Bootstrap 3.8.10 (Fri Oct  5 23:52:39 UTC 2018)

SD/MMC: Image: Read file u-boot.bin to 0x73f00000
SD: Card Capacity: Standard
SD: Specification Version 3.0X
SD/MMC: Done to load image
RomBOOT


AT91Bootstrap 3.8.10 (Fri Oct  5 23:52:39 UTC 2018)

SD/MMC: Image: Read file u-boot.bin to 0x73f00000
SD: Card Capacity: Standard
SD: Specification Version 3.0X
SD/MMC: Done to load image
RomBOOT

Last edited by jmaxxz on Mon Oct 22, 2018 6:16 pm, edited 1 time in total.
blue_z
Location: USA
Posts: 1763
Joined: Thu Apr 19, 2007 10:15 pm

Re: at91sam9m10g45-sd appears to crash after bootstrap

Tue Oct 09, 2018 3:15 am

jmaxxz wrote: I have been trying to get a at91sam9m10g45ek equivalent board to boot linux from sd card.
What exactly is an "equivalent board"?
Has this board ever booted from SDcard?

Regards
jmaxxz
Posts: 2
Joined: Mon Oct 08, 2018 9:57 pm

Re: at91sam9m10g45-sd appears to crash after bootstrap

Wed Oct 10, 2018 10:12 pm

What exactly is an "equivalent board"?
It is a board with a at91sam9m10g45 which appears to have used the AT91SAM9G45-EKES as a reference design less the screen, ac97, and video out.

Has this board ever booted from SDcard?
I am told it has, but only Windows CE.
blue_z
Location: USA
Posts: 1763
Joined: Thu Apr 19, 2007 10:15 pm

Re: at91sam9m10g45-sd appears to crash after bootstrap

Fri Oct 12, 2018 10:34 pm

You haven't provided sufficient details (not even which release of Yocto) of what you're doing, so there can be no evaluation of where things went wrong.
I can however confirm that your at91sam9m10g45ek-sd.conf can produce AT91Bootstrap and U-Boot binaries that can boot an authentic AT91SAM9M10G45-EK.

Regards

Return to “SAM9 ARM9 MPU”

Who is online

Users browsing this forum: Google [Bot] and 6 guests