Error while ccompiling linux for AT91SAM9263

All design tool related questions: compiler, assembler, linker. Embedded programming questions: assembler, C code.

Moderator: nferre

vijaya_svk
Posts: 9
Joined: Sat Dec 13, 2008 6:18 am

Error while ccompiling linux for AT91SAM9263

Fri Feb 13, 2009 8:19 pm

Hi
I followed the steps given in the linux4sam and i executed
$ bitbake angstrom-x11-image-demo

Then i am facing the following errors................


| checking for gcc -fexceptions... yes
| checking for __builtin_expect... yes
| checking for __builtin_memset... no
| checking for redirection of built-in functions... yes
| checking for __thread... no
| checking for libgd... no
| checking for egrep... grep -E
| checking for ANSI C header files... no
| checking for sys/types.h... no
| checking for sys/stat.h... no
| checking for stdlib.h... no
| checking for string.h... no
| checking for memory.h... no
| checking for strings.h... no
| checking for inttypes.h... no
| checking for stdint.h... no
| checking for unistd.h... no
| checking for long double... no
| checking size of long double... (cached) 8
| running configure fragment for ports/sysdeps/arm/elf
| checking for ARM TLS support... no
| running configure fragment for ports/sysdeps/unix/sysv/linux/arm/eabi/nptl
| running configure fragment for ports/sysdeps/unix/sysv/linux/arm/eabi
| running configure fragment for nptl/sysdeps/pthread
| configure: error: compiler support for __thread is required
| FATAL: oe_runconf failed
NOTE: Task failed: /stuff/tmp/work/armv5te-angstrom-linux-gnueabi/glibc-intermediate-2.5-r6/temp/log.do_configure.4709
NOTE: package glibc-intermediate-2.5-r6: task do_configure: failed
ERROR: TaskFailed event exception, aborting
NOTE: package glibc-intermediate-2.5: failed
ERROR: Build of /stuff/org.openembedded.dev/packages/glibc/glibc-intermediate_2.5.bb do_configure failed
ERROR: Task 890 (/stuff/org.openembedded.dev/packages/glibc/glibc-intermediate_2.5.bb, do_configure) failed
NOTE: Tasks Summary: Attempted 198 tasks of which 198 didn't need to be rerun and 1 failed.
ERROR: '/stuff/org.openembedded.dev/packages/glibc/glibc-intermediate_2.5.bb' failed


How can i resolve this error...........

Return to “Development Tools”

Who is online

Users browsing this forum: No registered users and 3 guests