Page 1 of 1

Serious Issues Using SAM-BA

Posted: Thu Oct 06, 2016 10:31 pm
by PeterT
I'm using linux on my host machine and trying to use SAM-BA with the SAMA5D2 XPLAINED (rev B). Initially, any command I tried to failed with

Code: Select all

"Opening serial port 'ttyACM0'
Error: Could not switch monitor on port 'ttyACM0' to binary mode
Connection closed.
I finally used a terminal program (C-Kermit) to manually connect to the port (had to set the baud rate to 57600 instead of 115200 as stated in the datasheet) and use the N# command. Then my commands at least got farther.

No any time I try to use an applet, I get the following

Code: Select all

sam-ba --port serial:ttyACM0:57600 --board sama5d2-xplained --applet bootconfig
Connection opened.
<path>/tools/sam-ba_3.1.4/qml/SAMBA/Applet.qml:96: Error: Could not initialize applet (status: undefined)
Connection closed.
It's the same for any applet. This has been ridiculously frustrating. Please, someone help me out with this.

Re: Serious Issues Using SAM-BA

Posted: Tue Jul 02, 2019 6:21 am
by elyask
Hi Peter,

I am having the same issue. I would like to know if you have solved your problem. If yes how?

Thanks
Elyas