Page 1 of 1

Search function in forum not working correctly

Posted: Sun Feb 03, 2008 3:08 pm
by Gustav
Hi

Thanks for a nice site with lots of information for AT91 development.

I have found one problem with the search in forums. Sometimes the search function comes up with no results eventhough there are many posts that fits the search criteria... But most of the time the search functions nicely...

If you search for 'USB' in all forums there obviously should be plenty of hits, but there are null.

Posted: Tue Mar 25, 2008 7:26 am
by spinality
LOL that was exactly my experience, including the same search term.

Posted: Tue Mar 25, 2008 7:49 am
by limpens
spinality wrote:LOL that was exactly my experience, including the same search term.
I guess the search term is too short. (searching for usb0 does give me results).

Re: Search function in forum not working correctly

Posted: Thu Feb 12, 2009 10:53 am
by framak
some words are not considered in the search

i looked for usb and got no results because the term is too common

so i used "usb problem" the result is that "usb" is ignored and all messages with the word "problem" is returned also the ones not including the word usb

this is a part of the at91.com site that can definitely has room for improvement.

Re: Search function in forum not working correctly

Posted: Sat Feb 28, 2009 4:11 pm
by nat
I will double check this issue and keep you informed once it is fully running.

Re: Search function in forum not working correctly

Posted: Thu Jun 18, 2009 3:21 pm
by jnewcomb
Wow.. doesn’t anyone else find the pre-filtering of search strings really obstructive, to the point of making the forum unusable?
When I have a problem, I often type in deliberately vague searches about the symptoms - and then skim read the titles to check for possible causes..
Example, if I type:
"missing spi interrupt"

then I am informed the following keywords are ignored:
'interrupt spi'
...because they are too common.

And instead I get results returned on only one keyword... 'missing'... such and missing parts, missing files..
Unbelievable!

Re: Search function in forum not working correctly

Posted: Sat Sep 19, 2009 9:58 am
by nat
Hello
we are working on an update of the forum and the search engine will be updated.
Do not hesitate to send us your feedback.

Re: Search function in forum not working correctly

Posted: Thu Apr 14, 2011 12:43 pm
by sven-de
Even though this post is a little old, I still observe the same malfunction with the search. I just tried to search for "can interrupt" and was told that those terms are ignored. Please, how am I supposed to redefine my query without using the terms this is all about?

Meanwhile I'm using google with the site:at91.com option, but this lacks a lot of filters the forum-search does offer. So please, fix this PITA!

Re: Search function in forum not working correctly

Posted: Thu Oct 27, 2011 1:23 pm
by jnewcomb
I wanted to list all posts that mentioned the 'CAN status register'
It is call 'CAN_SR' in the datasheet.

I typed in 'CAN_SR' into the search and this is what I got back...
>Search term used: 'can sr' - ignored: can

This is just so wrong in sooooo many ways!
Needless to say, the returned results were useless.

This thread is nearly four years old now.. Please forum admins, read through the suggestions made here.. this forum _could_ be a very useful resource..
Thanks.

Re: Search function in forum not working correctly

Posted: Sun Mar 03, 2013 12:59 am
by blue_z
The search function is still rather crippled.
In general, a forum search tends to return stale results (i.e. old posts) and recent posts are not found.

A search for "spi" or "SPI" returns the limit of 50 posts, but the most recent post is dated 2007.
Also, specifying "exact phrase" still returns bogus matches like "suspicious".

Typically the most recent posts that were returned seemed to be from 2007 or 2011 (depending on the search term).
Is there some search or keyword database that needs to be refreshed?

Regards

Clarification
I'm commenting on the "Search" function of this site, not the "forum search" which still filters (key)words out.