SAM4E-EK DEMO1 throws 534 warnings when built w AtmelStudio

Moderator: nferre

mars
Posts: 2
Joined: Thu Mar 27, 2014 9:09 pm

SAM4E-EK DEMO1 throws 534 warnings when built w AtmelStudio

Thu Mar 27, 2014 9:29 pm

I just received my SAM4E-EK today to use in evaluating the ARM for our new product. The eval kit worked when first plugged in. Using AtmelStudio 6.2, successfully built and programmed the eval kit with GETTING_STARTED1 project. After running this project, I moved on to the SAM4E_EK_DEMO1 project in order to build and program the eval kit with this firmware. During the build process a total of 534 warnings were created. The resulting code successfully programmed the eval kit and started, but never goes past the "IP Configuration" screen.

Tried to attach Build output file with warnings but forum won't accept txt or pdf. :? :?
mars
Posts: 2
Joined: Thu Mar 27, 2014 9:09 pm

Re: SAM4E-EK DEMO1 throws 534 warnings when built w AtmelStu

Fri Mar 28, 2014 3:33 pm

Please forgive me while I vent on this issue. As an engineer looking to evaluate a processor, I purchased a fairly expensive eval kit and expected the demo program to build cleanly and function when downloaded to the eval hardware.

I ignored the warnings, which is the same (to me) as suppressing them, but the code does not function properly when downloaded. I tried to get tech support from the Atmel support website, but have been unable to set up an account and enter the issue.

Here is a sample of the warnings I'm seeing, most of which are of the "packed attribute causes inefficient alignment" type :
----------------------------------------------------------------------------
Warning 1 'color' may be used uninitialized in this function [-Wmaybe-uninitialized] C:\Users\marsenault\Documents\Atmel Studio\6.2\SAM4E_EK_DEMO1\SAM4E_EK_DEMO1\src\ASF\sam\components\display\ili93xx\ili93xx.c 421 2 SAM4E_EK_DEMO1[/size]
Warning 3 'p_tx_cb' may be used uninitialized in this function [-Wmaybe-uninitialized] C:\Users\marsenault\Documents\Atmel Studio\6.2\SAM4E_EK_DEMO1\SAM4E_EK_DEMO1\src\ASF\sam\drivers\gmac\gmac.c 760 8 SAM4E_EK_DEMO1
Warning 4 variable 'fmr_backup' set but not used [-Wunused-but-set-variable] C:\Users\marsenault\Documents\Atmel Studio\6.2\SAM4E_EK_DEMO1\SAM4E_EK_DEMO1\src\ASF\sam\drivers\pmc\pmc.c 1274 11 SAM4E_EK_DEMO1
Warning 5 nested extern declaration of 'vApplicationMallocFailedHook' [-Wnested-externs] C:\Users\marsenault\Documents\Atmel Studio\6.2\SAM4E_EK_DEMO1\SAM4E_EK_DEMO1\src\ASF\thirdparty\freertos\freertos-7.0.0\source\portable\memmang\heap_3.c 94 4 SAM4E_EK_DEMO1
Warning 6 cast increases required alignment of target type [-Wcast-align] C:\Users\marsenault\Documents\Atmel Studio\6.2\SAM4E_EK_DEMO1\SAM4E_EK_DEMO1\src\ASF\thirdparty\freertos\freertos-7.0.0\source\tasks.c 1732 3 SAM4E_EK_DEMO1
Warning 8 packed attribute causes inefficient alignment for 'addr' [-Wattributes] C:\Users\marsenault\Documents\Atmel Studio\6.2\SAM4E_EK_DEMO1\SAM4E_EK_DEMO1\src\ASF\thirdparty\lwip\lwip-1.4.0\src\include\ipv4\lwip\ip_addr.h 55 3 SAM4E_EK_DEMO1
[/size][/size]

Return to “SAM9-based”

Who is online

Users browsing this forum: No registered users and 1 guest