Atmel SAM9M10-G45-EK Evaluation board - Alignment Traps.

Moderator: nferre

Alistair.Gadd
Posts: 9
Joined: Sat Jan 19, 2013 11:57 am

Atmel SAM9M10-G45-EK Evaluation board - Alignment Traps.

Fri Jun 07, 2013 9:20 am

The Angstrom GPE GUI seems to be generating alignment traps just after booting every time. This is output from the DBGU serial after booting Linux:

at91sam9m10g45ek login: Alignment trap: gpe-confd (1072) PC=0x401b0e6c Instr=0x1
5840000 Address=0xbeeb820b FSR 0x813
Alignment trap: keylaunch (1074) PC=0x401ffd3c Instr=0xe5902004 Address=0x00019b
dd FSR 0x001
Alignment trap: keylaunch (1074) PC=0x401ff674 Instr=0xe594c004 Address=0x00019b
dd FSR 0x001

This seems to be happening on both of the two boards that we have bought for our current project, running the Atmel / Angstrom demo Linux distro. I get exactly the same messages when I make a bootable SD card. I've tried a 64MB config and a 128MB config using "make menuconfig". (It allows 256MB as well, and "free" thinks it's there, but I don't see how it can be, because the second EBI_DDR2 bank isn't configured in ddram_init()).

The traps disappear if the runlevel is changed to 3 in /etc/inittab so that the GUI isn't started.

Has anybody else solved this problem, or know why it's occuring?

Return to “SAM9-based”

Who is online

Users browsing this forum: No registered users and 1 guest