Problem in SD-CARD Filesystem

Discussions around product based on ARM Cortex M7 core.
This forum will be discontinued soon.

Moderator: nferre

yudh
Posts: 3
Joined: Mon Jun 27, 2016 3:07 am

Problem in SD-CARD Filesystem

Mon Jun 27, 2016 9:47 am

Recently i met a problem, some unreadable files existed in my SD-CARD, and after I format it, the CARD is OK, but after 1 weeks continue running, it appeared again. I try to replace with new CARD, however there is no use.
The card inserted in WINDOWS7 PC shows in below, the filename looks like my data value inserted in database.

Image

Hardware: at91sam9g45 + nandflash + lpddr1
Kernel: linux3.8.1
MMC: at91sam9g45_MMC1, NOT MMC0. formated in PC with FAT32 filesystem, MMC clock set to 33MHz, 133/(2 * (1+1)) = 33, MCK / (2* (CLKDIV + 1)), CLKDIV is set to 1 in HSMIC_MR regsiter.
How can I modify the CLKDIV value? I try to modify <linux/drivers/mmc/host/atmel-mci.c> atmci_set_ios() function.
Mount the card with command : mount -t vfat -o errors=continue /dev/mmcblck0p1 /media/storage;

With SD-CARD I use SQLITE3 database, insert some realtime data per 30 seconds. The app Create a <*.db> file, which is <open()> from power on to power down or reset, never <close>, so the card can not been umounted.

In linux shell, <ls> command printed more debug message:
ls: ./NFAT-fs (mmcblk0p1): error, invalid access to FAT (entry 0x3d672d31)
SELECT. 4,: Input/output error
ls: ./ELECT 5,.200: Input/output error
ls: ./0304,nul.L,N: Input/output error
ls: ./CT 7,200.39,: Input/output error
ls: ./8,20038,.146: Input/output error
ls: ./time_dat.a]:: Input/output error
ls: ./s]:(S->C.)##: Input/output error
ls: ./c->s)##0.389: Input/output error
ls: ./ST=31;CN.=20: Input/output error
ls: ./01605292.236: Input/output error
ls: ./Flag=N;S.09-: Input/output error
ls: ./g=N;02-R.td=: Input/output error
ls: ./02-flag=.N;0: Input/output error
ls: ./S05-Flag.=n;: Input/output error
ls: ./02-rtd=1.2.8: Input/output error
?????NJW.A?? ???????N.JW1 ????.??? WK??????.??? n!w!??
??NJWA?.t?? ???????N.JW1 ?NHW!?$%.??? a_Rtd],[.Vic nw'????4
??NGWK??.??? ???????N.jw1 D?.?b? an't get. on s encryp.ted
???NHW!?.?k? ???????n.JW1 HW!?@???.??? backup up_down_rec
?NJWA???.??? ???????n.JW1 NGWK????.??? cl?gm???.??? x?5?????.??n
?c.??? ??????.NW( NION SEL.ect data.db ????.???
? CSDB.[T.B_R NJWA?\.?.??? flow_rec.db ????????.NJW
?[select. [i #WCLdGY?.??? TG??????.??n k?.???
???????N.hw! 44:03 da.tab Time]) S.ele log
???????n.jwa ??????NG.WK? WA?x.??? ltime_da.ta]
[root@DATE7300S storage]#

Hope for resolve this problem or give some suggestions.
yudh
Posts: 3
Joined: Mon Jun 27, 2016 3:07 am

Re: Problem in SD-CARD Filesystem

Fri Jul 08, 2016 7:59 am

Please change the problem to <SAM9 ARM9 MPU> forum, I did't found the way to move it, thanks

Return to “SAM Cortex-M7 MCU”

Who is online

Users browsing this forum: No registered users and 1 guest