Page 1 of 1

ATSAMA5D27-SOM1-EK1 Image file not Booting

Posted: Tue Aug 06, 2019 10:31 am
by ChaitanyaVarma
Hi, I'm a Beginner in this field.

I'm trying to boot the ATSAMA5D27 SOM board but it is not booting i would mention the procedure which i have followed below.

1.

Step1:link https://github.com/linux4wilc/wilc_demo ... 27_som1_ek

From this link Downloaded the README file and followed the steps mentioned in the file.


Step2: After very long time all downloads were finished and the final image was created and successfully flashed the image into SD card. Before Flashing SD card was formatted using SD card Format.


Step3: Then connected the wires as per the connections specified in the File. WIFI driver is also inserted into the slot J12.


Step4: Used minicom to access the COM port. Here after reinserting the SD card into SD card slot pressed the PB1(NRST) pin than it is just showing the RomBOOT and booting is not happening.


2. Do we have to use any display to know whether the booting is happening are not..?

Re: ATSAMA5D27-SOM1-EK1 Image file not Booting

Posted: Wed Aug 07, 2019 12:45 am
by blue_z
ChaitanyaVarma wrote: Step2: After very long time all downloads were finished and the final image was created and successfully flashed the image into SD card. Before Flashing SD card was formatted using SD card Format.
You need to provide the exact details of how you "flashed the image into SD card".

ChaitanyaVarma wrote: 2. Do we have to use any display to know whether the booting is happening are not..?
No, the serial console is sufficient.

Regards

Re: ATSAMA5D27-SOM1-EK1 Image file not Booting

Posted: Wed Aug 07, 2019 6:44 am
by ChaitanyaVarma
This is the procedure which i followed to Boot my ATSAMA5D27 SOM kit.

1. Clone buildroot using below command
git clone https://github.com/linux4sam/buildroot-at91.git -b linux4sam_6.0
2.Unzip the buildroot_external.zip available at the Github page
cd buildroot-at91
3. Run below command to set the configuration
BR2_EXTERNAL=../buildroot_external/ make sama5d27_som1_ek_wilc_defconfig
4. Run the below command to start the build
make
This command downloads necessary package required for buildroot.

5. Updating kernel with WILC driver and firmware:
Remove old driver files
rm -rf buildroot-at91/output/build/linux-linux4sam_6.0/drivers/staging/wilc1000/*
6. Clone the WILC driver code from github using below command

git clone git://github.com/linux4wilc/driver
User can clone this driver to any temporary folder.

7. Copy WILC cloned “driver/wilc” files to “buildroot-at91/output/build/linux-linux4sam_6.0/drivers/staging/wilc1000” folder.

cp -rf <cloned_dir>/ driver/wilc/* buildroot-at91/output/build/linux-linux4sam_6.0/drivers/staging/wilc1000/

8. Modify the following line in “buildroot-at91/output/build/linux-linux4sam_6.0/drivers/staging/Makefile” so that the build finds the correct directory

FROM: obj-$(CONFIG_WILC1000) += wilc1000/
TO: obj-$(CONFIG_WILC) += wilc1000/

9. Updating WILC firmware:
WILC Firmware desired version can be updated in the “buildroot_external\package\wilc-firmware\wilc-firmware.mk” file. Current buildroot external is using WILC 15.2.User can change to any stable version of WILC firmware. Released WILC firmware information is available at: https://github.com/linux4wilc/firmware/releases

10. Run the below command to rebuild the kernel
make linux-rebuild
Run the below command to update kernel in buildroot.
make
Note: WILC driver and firmware should of the same version number (example: WILC 15.2). This release is tested with WILC 15.2 driver and firmware. User should follow above steps to upgrade to any WILC driver or firmware version.

On successful compilation an “images” folder is created under “buildroot-at91/output” folder.
This folder will have the final image “sdcard.img” which needs to be programmed in a SD card.

11. By using Etcher Flashed image file into SD card before flashing SD card was Formatted.

Please let me know whether i followed the right way to create an image.

Re: ATSAMA5D27-SOM1-EK1 Image file not Booting

Posted: Fri Aug 09, 2019 1:31 am
by blue_z
Since you initially reported a booting issue, I only asked for "the exact details of how you 'flashed the image into SD card'".
Your response of "11. By using Etcher Flashed image file into SD card ..." barely qualifies as an adequate explanation.

Have you booted this board with any SD card?

Mount that SD card using a Linux PC, and list the contents of the first partition.

Regards

Re: ATSAMA5D27-SOM1-EK1 Image file not Booting

Posted: Mon Aug 12, 2019 3:32 pm
by ChaitanyaVarma
Thank you for the attention you are giving to answer my quires and also sorry for the inappropriate information by me.
1. After Flashing the image into micro SD card i can see two partitions.
a) W95 FAT32 (LBA) (Bootable) of 17MB.
b)Ext4 of 537MB.

2. I'm mentioning the file names which are present in the first partition.
a)boot.bin
b)sama5d2_xplained.itb
c)uboot.env
d)u-boot.bin

I hope I'm making sense. Please let me know if any further information required.

Thank you

Re: ATSAMA5D27-SOM1-EK1 Image file not Booting

Posted: Tue Aug 13, 2019 12:26 am
by blue_z
ChaitanyaVarma wrote: Please let me know if any further information required.
You could respond to my other question, have you (ever sucessfully) booted this board with any SD card?

Regards

Re: ATSAMA5D27-SOM1-EK1 Image file not Booting

Posted: Tue Aug 13, 2019 6:29 am
by ChaitanyaVarma
No, This is the first time I'm trying to boot on this board. Previously i tried in a different way than the 'D5' led turned blue from Red and some files were downloaded even though that process was not successful.

1. In the console window it is just showing RomBoot and not Booting in the current procedure which I'm trying.


Thank you

Re: ATSAMA5D27-SOM1-EK1 Image file not Booting

Posted: Tue Aug 13, 2019 11:37 pm
by blue_z
ChaitanyaVarma wrote: No, This is the first time I'm trying to boot on this board.
Then you should try booting with a proven pre-built image from Linux4SAM.

Regards