Page 1 of 1

Unable to program BUREG

Posted: Wed Jul 17, 2019 8:07 pm
by mjacques4
We have been using an ATSAMA5d27-SOM1-EK board to develop an application for several months. Suddenly today, it will no longer allow us to program the Backup Registers using SAM-BA.

The board boots into the SAM-BA monitor and I am able to successfully execute commands.
No error is given when I attempt to use SAM-BA to write to the backup registers, but if I immediately read back the value, it is always 0x00000000.
I am able to use SAM-BA to program the BSCR register successfully, just not any of the 4 BUREGs.

Even if I had burned in the DISABLE_BSCR fuse bit, I should be able to write to the BUREG, correct? I double checked the fuse to make sure that bit wasn't set, and apparently some of the fuse bits ARE set, (but not DISABLE_BSCR) which is odd, because I have never explicitly set the fuse. Not sure if that is related to this issue or not.

I have been using these scripts to program the BUREG for months without any issues. I have also tried these scripts with an ATSAMA5D27-D5M-CU chip on our final hardware and it still works fine.

Has anyone seen this before? Any idea what I might be doing wrong?

Thanks!

Re: Unable to program BUREG

Posted: Thu Jul 18, 2019 1:13 am
by blue_z
Verify the VDDBU voltage and circuitry, e.g. jumper J4 and the Supercap.

Regards

Re: Unable to program BUREG

Posted: Thu Jul 18, 2019 3:36 pm
by mjacques4
Verify the VDDBU voltage and circuitry, e.g. jumper J4 and the Supercap.

I was thinking it might be something like that, but wouldn't a power issue prevent me from writing the BSCR as well?

I will check those today.

Thanks.