applet-lowlevelinit-sama5d3x.bin won't run under Ubuntu 18.04.2 LTS

Moderator: nferre

oldcabman
Posts: 2
Joined: Tue Dec 14, 2010 1:15 am

applet-lowlevelinit-sama5d3x.bin won't run under Ubuntu 18.04.2 LTS

Mon May 13, 2019 7:26 pm

I'm attempting to run SAM-BA in the 18.04.2 LTS release. Followed the directions in the app note an-8995. Launching sam-ba_64, the small connection GUI window comes up, shows the serial connection (ACM0) and allows me to select the Xplained board package. After hitting "connect", the connection is established, the chip's device ID is successfully read, but then the process stops when applet-lowlevelinit-sama5d3x.bin is run. Here's what's shown on my terminal:

frank@frank-VirtualBox:~/sam-ba_cdc_linux$ ./sam-ba_64
-I- Waiting ...
-I- TCL platform : Linux
-I- SAM-BA CDC 2.18 on : linux
-I- Connection : /dev/ttyACM0 (target(comType) = 0)
-I- Board : at91sama5d3x-ek
-I- Traces Level : 4
-I- target(handle) : file5
-I- sourcing board description file /home/frank/sam-ba_cdc_linux/tcl_lib/at91sama5d3x-ek/at91sama5d3x-ek.tcl
Read device Chip ID at 0xFFFFEE40 --- get 0xffffffff8a5c07c2
-I- Found chip : at91sama5d3x (Chip ID : 0xffffffff8a5c07c2)
-I- Loading applet applet-lowlevelinit-sama5d3x.bin at address 0x308000

It simply stops right there. I can hit Enter and get it to respond with a cr/lf, that's it. Can someone suggest a way to debug this problem?
blue_z
Location: USA
Posts: 1971
Joined: Thu Apr 19, 2007 10:15 pm

Re: applet-lowlevelinit-sama5d3x.bin won't run under Ubuntu 18.04.2 LTS

Tue May 14, 2019 8:28 pm

There's a discrepancy in your description.
You mention that you "select the Xplained board package", but the log indicates that the actual specification was for the "-I- Board : at91sama5d3x-ek".
What board are you using?

BTW I've seen SAM-BA 2.18 execute with Lubuntu 18.04.2 LTS.


Regards

Return to “SAMA5-based”

Who is online

Users browsing this forum: No registered users and 1 guest