SAMA5D3 XPLAINED problem while flashing buildroot output

Moderator: nferre

GuidoR
Posts: 1
Joined: Thu Mar 29, 2018 11:54 am

SAMA5D3 XPLAINED problem while flashing buildroot output

Thu Mar 29, 2018 1:08 pm

Dear Reader,

I'm having some trouble when trying to flash my SAMAD3 XPLAINED board with my newly created buildroot output (with Ubuntu 16.04, on VBox). What I did to build my output is the following:

make atmel_sama5d3_xplained_defconfig
make

After a while all is build and I try to flash the ouput into the NAND-flash using SAM-BA. However, I keep getting the same message:

~/buildroot/buildroot$ board/atmel/flasher.sh ~/buildroot/buildroot/output /dev/ttyACM0 sama5d3_xplained
Executing: sama5d3_xplained O=/home/guido/buildroot/buildroot/output/images /home/guido/buildroot/buildroot/output/host/opt/sam-ba/sam-ba /dev/ttyACM0 at91sama5d3x-xplained board/atmel/nandflash.tcl -- sama5d3_xplained at91-sama5d3_xplained.dtb video=LVDS-1:800x480-16
-I- Waiting ...
-I- TCL platform : Linux
-I- SAM-BA CDC 2.16 on : linux
couldn't load file "/tmp/tclzTnSrw": libX11.so.6: cannot open shared object file: No such file or directory
while executing
"load /home/guido/buildroot/buildroot/output/host/opt/sam-ba/sam-ba/lib/tk8.5/../libtk8.5.so Tk"
("package ifneeded Tk 8.5.9" script)
invoked from within
"package require Tk 8.1.1"
("package ifneeded BWidget 1.9" script)
invoked from within
"package require BWidget"
(file "/home/guido/buildroot/buildroot/output/host/opt/sam-ba/sam-ba/lib/tkcon.tcl" line 131)
invoked from within
"source [file join $starkit::topdir lib/tkcon.tcl]"
(file "/home/guido/buildroot/buildroot/output/host/opt/sam-ba/sam-ba/main.tcl" line 7)


Here's a snippit of dmesg after connecting the board:

[11364.140822] usb 1-2: New USB device found, idVendor=03eb, idProduct=6124
[11364.140823] usb 1-2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[11364.187079] cdc_acm 1-2:1.0: ttyACM0: USB ACM device
[11364.198618] usbcore: registered new interface driver cdc_acm
[11364.198619] cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters

Anyone any idea what's going wrong?
blue_z
Location: USA
Posts: 1703
Joined: Thu Apr 19, 2007 10:15 pm

Re: SAMA5D3 XPLAINED problem while flashing buildroot output

Fri Mar 30, 2018 8:36 pm

GuidoR wrote:I'm having some trouble when trying to flash my SAMAD3 XPLAINED board with my newly created buildroot output (with Ubuntu 16.04, on VBox).
You neglect to provide salient details.
What version of Buildroot?
Is this a 64-bit build environment?

GuidoR wrote:Anyone any idea what's going wrong?
If you have a 64-bit build environment, either have 32-bit runtime capability or execute the 64-bit version of the SAM-BA utility.

Regards
jhenderson
Posts: 1
Joined: Thu Apr 12, 2018 11:00 pm

Re: SAMA5D3 XPLAINED problem while flashing buildroot output

Fri Apr 13, 2018 12:15 am

This issue has been fixed in the latest upstream buildroot. Please see the following commits on the master branch.

e1452fe board/atmel: use correct sam-ba binary in flasher.sh script
b3b5608 sam-ba: fix sam-ba symbolic link

The issue is that the correct binary needs to be chosen, either "sam-ba" or "sam-ba_64", based on your host arch.

Return to “SAMA5-based”

Who is online

Users browsing this forum: No registered users and 2 guests