at91bootstrap binary file for sama5d27-som1-ek

Moderator: nferre

2Dooc
Posts: 4
Joined: Wed Jan 31, 2018 11:37 am

at91bootstrap binary file for sama5d27-som1-ek

Wed Jan 31, 2018 4:23 pm

Hello everyone.

I'm totally new on linux and the community plus i'm a beginner at coding, so for those who wants to take some of their time to help a newbie, i will appreciate and thanks them .

My goal is to boot the sama5d27-som1-ek board. I follow the step given here: linux4sam/bin/view/Linux4SAM/Sama5d27So ... ource_code.

I'm currently trying to get the at91bootstrap binary file for the board. Here what i got:
:~/at91bootstrap$ make mrproper
CLEAN obj and misc files!
CLEAN configuration files!
CLEAN binary files!
:~/at91bootstrap$ make sama5d27_som1_eksd_uboot_defconfig
#
# configuration written to .config
#
#
# make dependencies written to .auto.deps
# See top of this file before playing with this auto-preprequisites!
#
What I understand form this message is when the makefile is execute in order to create the .config file, it can't create it because there is a dependency problem with a .auto.deps file. File which i don't find anywhere. Is it missing and i need it (how to get it?) which explains the error or am i totally wrong and the problem come from somewhere else ? How can i fix it ?

Thank you all

Sincerely

2Dooc
blue_z
Location: USA
Posts: 1676
Joined: Thu Apr 19, 2007 10:15 pm

Re: at91bootstrap binary file for sama5d27-som1-ek

Thu Feb 01, 2018 1:23 am

2Dooc wrote:I'm totally new on linux and the community plus i'm a beginner at coding,
So study How To Ask Questions The Smart Way.
Also learn how to format your post (using either quote or code blocks) so that terminal dialogue is distinguishable from your text.

2Dooc wrote:I follow the step given here: linux4sam/bin/view/Linux4SAM/Sama5d27So ... ource_code.
That's not an adequate description of what you did.
What is your host system (e.g. 32 or 64 bit) (e.g. Linux distro or Cygwin)?
What toolchain are you using (e.g. distro package or Linaro download)?

2Dooc wrote:What I understand form this message is when the makefile is execute in order to create the .config file, it can't create it because there is a dependency problem with a .auto.deps file. File which i don't find anywhere. Is it missing and i need it (how to get it?) which explains the error or am i totally wrong and the problem come from somewhere else ?
How did you look for this file?
Perhaps you need to pause, and take a course in how to use Linux?
FYI a filename that begins with a period, such as .auto.deps, is considered a hidden file, and simple directory listing commands will not display it.
Regardless this verbose output from the 'make' command is not an error as you incorrectly assume. (Describe the problem's symptoms, not your guesses.)
Warning and error messages, when they are generated, will clearly include those salient words .

2Dooc wrote:How can i fix it ?
I see no "error" that needs fixing.
What you have posted is the normal output of those two steps. The two "xxx written to yyy" lines indicate success.
There is no need to modify any auto-preprequisites, so that message can be ignored.
You can proceed with a 'make menuconfig' (for further configuration) or 'make' (to build the program).

Regards
2Dooc
Posts: 4
Joined: Wed Jan 31, 2018 11:37 am

Re: at91bootstrap binary file for sama5d27-som1-ek

Wed Feb 07, 2018 12:21 pm

HI blue_z

Sorry to reply late

I just wanted to thank you for your answer.
I finally succeed to boot with an SD card.

I will study the link you sent me before to do another post.

Regards

Return to “SAMA5-based”

Who is online

Users browsing this forum: No registered users and 2 guests