Page 1 of 1

Has anyone been able to successfully implement an IDE solution for the sama5dx?

Posted: Fri Dec 01, 2017 9:32 am
by zdhovey2000
After spending several days now looking for a way to develop applications on an IDE such as Eclipse, I've yet to find a working solution. I pulled a few documents from Microchip, but the documentation was outdated and was a dead end.

I've tried adding the Yocto Project Plugin to Eclipse and using pieces of data from Microchip and a couple of other publications, however, I had problems adding the toolchain which resulted in Eclipse locking up. I also tried to build a route using the GDB server over a static ip address, but there again, what they gave me turned out to be out of date.

Next, I've tried using this as a template sort of example:
https://community.nxp.com/docs/DOC-172840

However, it seems Atmel has configured Yocto differently as I am unable to find or build a similar example for:
$ bitbake meta-toolchain

Anyway, this is where I'm at now.

I've been able to use the board, such as building on to the demo Yocto Project to add fairly simple recipes, or running .py scripts to test the basic functionality of the board, but ultimately, our key feature really needs a debug environment. So I have to ask, has anyone been able to get an IDE running suitable for developing applications and debugging (with breakpoints, etc)?

If not, what am I missing here? This seems rather odd for Microchip to have this MPU but with little documentation and no clear guide to getting us up and running doing what we do best, application development.

Re: Has anyone been able to successfully implement an IDE solution for the sama5dx?

Posted: Mon Dec 04, 2017 6:17 pm
by nferre
Hi,

You can download ready-to-use generated SDK here:
https://www.at91.com/linux4sam/bin/view ... roject_SDK
and insert it as a cross-compilation environment for Eclipse.

Best regards,