Linux Demo on SAMA5D27-SOM1-EK1

For SAMA5D2 Xplained, SAMA5D3 Xplained and SAMA5D4 Xplained

Moderator: nferre

Posts: 2
Joined: Mon Nov 20, 2017 11:14 am

Linux Demo on SAMA5D27-SOM1-EK1

Mon Nov 20, 2017 12:57 pm


I'm having trouble getting the demo linux4sam image running on the ATSAMA5D27-SOM1-EK1.

The jumpers are all set to default positions.

I've downloaded the image from ... .7.img.bz2, verified the md5 and used Etcher 1.1.2 under windows to flash the image to a 8gb sdhc card.

When I boot the development board I get the following message on the console :

AT91Bootstrap 3.8.9 (Tue Oct 3 11:21:45 CEST 2017)

SD/MMC: Image: Read file u-boot.bin to 0x23f00000
SDHC: Error: No Card Inserted
*** FATFS: f_open, filename: [u-boot.bin]: error
SD/MMC: Failed to load image

I presume the board/system is compatible with an SDHC card ?

Any suggestions are greatly appreciated.
Thomas Sidwick
Location: USA
Posts: 1568
Joined: Thu Apr 19, 2007 10:15 pm

Re: Linux Demo on SAMA5D27-SOM1-EK1

Mon Nov 20, 2017 10:57 pm

ThomasSidwick wrote:I presume the board/system is compatible with an SDHC card ?
The system did read one binary image from your SDcard, and is executing that program.
It's a multi-stage boot to get the Linux kernel loaded.
The RomBOOT will load the boot.bin file (the AT91Bootstrap image) from the SDcard, which in turn loads the u_boot.bin file, which in turn loads the kernel and DT blob.

The error message actually indicates an issue with the electromechanical switch and input line which indicates whether an SDcard is properly inserted or not. If your SDcard is not physically defective, then this would likely be a board issue.
I have never seen such an error message in a few hundred SDcard boots, and on the occasions that the SDcard was not properly or fully seated in the socket, it was RomBOOT that would (silently) ignore the SDcard.

To be sure, jiggle the SDcard so that it is firmly seated in the socket.

ThomasSidwick wrote:Any suggestions are greatly appreciated.
Try a different SDcard. A single failure isn't going to convince anyone that it's a board issue.
For a simple test you need only copy the boot.bin and u-boot.bin files to a FATFS per these directions: How to make a bootable SD card.

Since I have found AT91Bootstrap to be more fussy than the RomBOOT (e.g. RomBOOT ignores the FATFS dirty bit, whereas AT91Bootstrap will respect it), you could modify AT91Bootstrap to ignore this error condition, and see if it can proceed with loading the U-Boot image anyway.
If that's beyond your current skill level, then you may have to contact the merchant/vendor or Atmel/Microchip for advice.

Posts: 2
Joined: Mon Nov 20, 2017 11:14 am

Re: Linux Demo on SAMA5D27-SOM1-EK1

Thu Nov 23, 2017 5:55 pm

Thanks for your reply and suggestions, I've managed to boot the board with the same image on an SDCard rather than a micro SDCard.

As per your suggestion I tried a second micro sd card with the same result, the MMC/CD signal PA30 is getting as far as pin 94 on the SOM so I suspect a defect on the SOM.


Return to “SAMA5 Xplained”

Who is online

Users browsing this forum: No registered users and 1 guest