SAMA5D3 XPLD Serial problems

Moderator: nferre

artk2002
Posts: 5
Joined: Fri Oct 13, 2017 1:52 am

SAMA5D3 XPLD Serial problems

Mon Oct 30, 2017 10:50 pm

I'm trying to hook my SAMA5D3 up to a laptop running Fedora. I'm having the following problems:

1) The CDC connection gives an error. It gets an error=-71 when trying to read the device descriptor.
1a) Same error when connecting on a Win7 and a Win10 machine, after struggling with the Win drivers some.
2) The DBGU interface can connect, giving me a /dev/ttyUSB0 *but* gtkterm with the correct settings doesn't show any prompts or other information. It's just blank.

I know that the board is working correctly because I have a TM7000B attached and have the appropriate demo on an SD card. It boots from the SD card and the demo works fine.

So, any suggestions on how to get a console to work?
blue_z
Location: USA
Posts: 1704
Joined: Thu Apr 19, 2007 10:15 pm

Re: SAMA5D3 XPLD Serial problems

Tue Oct 31, 2017 8:33 pm

artk2002 wrote:1) The CDC connection gives an error. It gets an error=-71 when trying to read the device descriptor.
1a) Same error when connecting on a Win7 and a Win10 machine, after struggling with the Win drivers some.
Your descriptions are too vague to determine exactly what you have done.

artk2002 wrote:2) The DBGU interface can connect, giving me a /dev/ttyUSB0 *but* gtkterm with the correct settings doesn't show any prompts or other information. It's just blank.
Again your descriptions are too vague. Apparently you're trying to to use somekind of USB-to-serial adapter, but is it of the proper voltage (assuming it's a TTL connection) and connected to the proper pins?

artk2002 wrote:So, any suggestions on how to get a console to work?
Use the DBGU interface if you really want a console for all phases of boot.
If you want advice to correct the problem(s), then you have to first provide salient information.

Regards
artk2002
Posts: 5
Joined: Fri Oct 13, 2017 1:52 am

Re: SAMA5D3 XPLD Serial problems

Wed Nov 01, 2017 3:25 am

Thanks. My point was that even the DBGU interface wasn't working properly, although it at least created the /dev/ttyUSB0

Good news: I had tried two different USB-A cables for the regular interface and both had the same problem. I decided, for laughs, to try the USB-A that came with the TM7000B. For whatever reason, that one worked.
blue_z
Location: USA
Posts: 1704
Joined: Thu Apr 19, 2007 10:15 pm

Re: SAMA5D3 XPLD Serial problems

Wed Nov 01, 2017 8:11 pm

artk2002 wrote:My point was that even the DBGU interface wasn't working properly
But you listed it as the second of two distinct "problems".
Regardless, those are two independent peripheral interfaces. Look at the board schematics.
artk2002 wrote:... although it at least created the /dev/ttyUSB0
That's not salient diagnostic information because creating a device node for the USB adapter plugged into your PC is solely under control of that PC. Unless the adapter is powered by the target (highly unlikely), that device node is created when you plug it into the PC. Your target board can be unpowered or not even connected, and you would still see that device node created.

artk2002 wrote:I had tried two different USB-A cables for the regular interface ...
If there's a "regular" interface (for the console), then it would be the DBGU port.


Regards

Return to “SAMA5-based”

Who is online

Users browsing this forum: No registered users and 3 guests