Trouble flashing demo onto SAMA5D4-XULT

For SAMA5D2 Xplained, SAMA5D3 Xplained and SAMA5D4 Xplained

Moderator: nferre

zdhovey2000
Posts: 6
Joined: Fri Oct 13, 2017 9:52 pm

Trouble flashing demo onto SAMA5D4-XULT

Fri Oct 13, 2017 10:16 pm

I am trying to load the HDMI demo onto the SAMA5D4-XULT.

I'm able to connect via J11 (A5-USB-A), my Device manager lists "Bossa Program Port(COM 5)" and I can run sam-ba and it seems to connect fine. I can see the Memory Display window, but when I try to flash the demo by launching the .bat file I downloaded, the CMD window appears and runs, but then stops almost immediately and the logfile gives me this:

-I- Waiting ...
-I- TCL platform : Windows NT
-I- SAM-BA 2.17 on : windows
-I- Retrieved arguments from command line :
-I- argv 0 : -x
-I- argv 1 : demo_linux_nandflash_usb.qml
-I- argv 2 :
-I- Connection -x
-E- Connection -x not found
-E- Connection list : {\USBserial\COM5}

I've also tried connecting through J20 (EDBG), I get this:

-I- Waiting ...
-I- TCL platform : Windows NT
-I- SAM-BA 2.17 on : windows
-I- Retrieved arguments from command line :
-I- argv 0 : -x
-I- argv 1 : demo_linux_nandflash_usb.qml
-I- argv 2 :
-I- Connection -x
-E- Connection -x not found
-E- Connection list : COM5

Does anyone have any idea what could be causing this?
blue_z
Location: USA
Posts: 1547
Joined: Thu Apr 19, 2007 10:15 pm

Re: Trouble flashing demo onto SAMA5D4-XULT

Mon Oct 16, 2017 3:41 am

zdhovey2000 wrote:I am trying to load the HDMI demo onto the SAMA5D4-XULT.
...
-I- SAM-BA 2.17 on : windows
...
Does anyone have any idea what could be causing this?
You have provided few details, but managed to provide just enough salient information to give a clue as to what you're doing wrong.
Apparently you're trying to install Linux4SAM 5.7, which requires you to use SAM-BA 3.x (e.g. latest version is 3.2.1) as mentioned in the highlights on the welcome page . The directions you need to follow are here.
If you were installing Linux4SAM 5.3, then SAM-BA 2.17 would be the correct utility.

Regards
zdhovey2000
Posts: 6
Joined: Fri Oct 13, 2017 9:52 pm

Re: Trouble flashing demo onto SAMA5D4-XULT

Tue Oct 17, 2017 10:11 am

That was the culprit. Once I put the sam-ba in the path I was able to click on the .bat file and away it went. However, I never did get the hdmi demo to run. This is what I got:

<after booting>
Starting Demo... <=== just made a blank screen
Poky (Yocto Project Reference Distro) 2.2.2 sama5d4-xplained /dev/ttyS0
sama5d4-xplained login: root
root@sama5d4-xplained:~#

Oh well, moving on..

Thanks for the help!
blue_z
Location: USA
Posts: 1547
Joined: Thu Apr 19, 2007 10:15 pm

Re: Trouble flashing demo onto SAMA5D4-XULT

Wed Oct 18, 2017 9:45 pm

You could try:
A. changing the kernel command line parameter for the proper screen device (i.e. HDMI) and the screen resolution per "Choose supported (video) modes". This has to be done in the U-Boot environment variable bootargs.
B. the Linux4SAM 5.3 demo, which supports HDMI and the video decoder.

FWIW I tried installing the same 5.7 demo, and my board fails to even complete the kernel boot. It stalls with multiple I2C timeouts. Newer is not always better.

Regards

Return to “SAMA5 Xplained”

Who is online

Users browsing this forum: No registered users and 1 guest