Webserver on SAMA5D3-Xplained (Yocto/Linux) FASTCGI & PHP

Moderator: nferre

NTronix
Contact:
Location: Cambridgeshire United Kingdom
Posts: 5
Joined: Thu Jan 27, 2011 1:34 am

Webserver on SAMA5D3-Xplained (Yocto/Linux) FASTCGI & PHP

Sat May 28, 2016 1:10 pm

Hi All,

Has anyone else had any experiences with getting a webserver up and running on the SAMA5D3-XPlained board?

The original demo image as factory shipped had Lighttpd installed on it; which is fine but it only serves static pages (no PHP or CGI)

We updated our images to the demo V5.0 packages a while ago and notice that the support for the Lighttpd was removed.

So, we've downloaded the whole source for the demo package with a view to getting the webserver back as we'd like to use it.

Done this and after many hours of bitbake downloading sources and compiling we finally ended up with our own build of the demo image, that works just fine as with the pre-build image; still no Lighttpd though.

Now we wanted to add the Lighttpd back in, so edited the /poky/build-atmel/local.conf
to add CORE_IMAGE_EXTRA_INSTALL += "lighttpd"

Now rerun bitbake and we have a new image with the Lighttpd service

Great!

Well, not quite as we also want to add CGI and more importantly PHP support; however this is where my expertise ends and despite enabling "mod_fastcgi" in the ligttpd.conf file in /poky/meta/recipies-extended/lighttpd/lighttpd

it doesnt work as the fast-cgi module is missing throwing the following error message at boot:-

Code: Select all

Starting Lighttpd Web Server: 2016-05-28 08:43:20: (/home/garry/SAMA5D3_SW_20160114/poky/build-atmel/tmp/work/cortexa5hf-

vfp-poky-linux-gnueabi/lighttpd/1.4.36-r0/lighttpd-1.4.36/src/plugin.c.169) dlopen() failed for: /usr/lib/mod_fastcgi.so 

/usr/lib/mod_fastcgi.so: cannot open shared object file: No such file or directory
2016-05-28 08:43:20: (/home/garry/SAMA5D3_SW_20160114/poky/build-atmel/tmp/work/cortexa5hf-vfp-poky-linux-

gnueabi/lighttpd/1.4.36-r0/lighttpd-1.4.36/src/server.c.679) loading plugins finally failed lighttpd
So this is as far as I've been able to get.

Anyone have any ideas on how to get the fast-cgi module built and installed and how we then go about adding php support?


Your help would be appreciated

Thanks

Garry.

Return to “SAMA5-based”

Who is online

Users browsing this forum: No registered users and 3 guests