SAMA5D3 Xplained, SAM-ICE bad JTAG communication

Moderator: nferre

emacron
Posts: 2
Joined: Wed Sep 12, 2018 4:44 pm

SAMA5D3 Xplained, SAM-ICE bad JTAG communication

Wed Sep 12, 2018 5:06 pm

Hello,
I am new using SAMA5D3 Xplained board and SAM-ICE.
I have installed current SEGGER Embedded Studio for ARM, Windows, 32-bit version (V3.50).
I would like to start with loading and running 'Hello World' via SAM-ICE/J-LINK.
When I debug this program, I get following error message :

Preparing target for download
Executing script TargetInterface.resetAndStop()
Downloading ‘SAMA5D36HelloWorld.elf’ to J-Link
Programming 3.5 KB of addresses 00000000 — 00000e2f
Bad JTAG communication: Write to IR: Expected 0x1, got 0x0 (TAP Command : 10) @ Off 0x5.

Can someone help me for this ?
Thanks in advance
blue_z
Location: USA
Posts: 1716
Joined: Thu Apr 19, 2007 10:15 pm

Re: SAMA5D3 Xplained, SAM-ICE bad JTAG communication

Thu Sep 13, 2018 5:32 pm

A Google search for the salient error text "Bad JTAG communication: Write to IR" indicates that users typically resolve this by updating their J-Link firmware and/or a .dll file.

BTW downloading an ELF file is probably the wrong type of file in this situation.

Regards
emacron
Posts: 2
Joined: Wed Sep 12, 2018 4:44 pm

Re: SAMA5D3 Xplained, SAM-ICE bad JTAG communication

Tue Sep 18, 2018 9:20 am

Hello blue_z,
Thanks a lot for your reply and suggestions.
I got the clue from the Segger support.
I was using flash_placement.xml linker file, which is not properly set by default for SAMA5D3, though I wanted to debug in RAM !
They shared proper sram_placement.xml linker file and my debug is now working.
Best regards,

Return to “SAMA5-based”

Who is online

Users browsing this forum: No registered users and 3 guests