SAMD20 Erased after normal RESET or Power Down

Discussions around product based on ARM Cortex M0+ core.

Moderator: nferre

TPO
Posts: 2
Joined: Thu Sep 10, 2015 1:03 pm

SAMD20 Erased after normal RESET or Power Down

Thu Sep 10, 2015 1:08 pm

Hello my name is Túlio,
I´m having serious problem with mine SAMD20 and my JTAGICE3 programmer. When I program it, the code runs nice. but then when I reset or power down the board the code is erased. Anyone has any idea how to solve it?
Last edited by TPO on Thu Sep 10, 2015 1:15 pm, edited 1 time in total.
TPO
Posts: 2
Joined: Thu Sep 10, 2015 1:03 pm

Re: SAMD20 Erased after normal RESET or Power Down

Thu Sep 10, 2015 1:10 pm

I think that might be some memory writing problem, or maybe some fuse configuration. I´m still looking for the answer.
Thanks...
sarlacii
Posts: 68
Joined: Mon Jan 26, 2015 2:33 pm

Re: SAMD20 Erased after normal RESET or Power Down

Mon Sep 21, 2015 2:09 pm

Hi there

Just off the top of my head, check that you are not somehow setting erase before program or something similar? The IC won't just spontaneously erase... .
robbie
Posts: 13
Joined: Fri Dec 02, 2011 12:40 am

Re: SAMD20 Erased after normal RESET or Power Down

Tue Jul 05, 2016 11:02 pm

We had a similar thing with SAMD20 in sensor that is powered on/off every 4 seconds. We first estimated that this was caused by brown-out causing the processor to behave madly and unintentionally hitting a NVP driver function. So we adjusted BOD33 levels. This did not help. Eventually we set the lock bits for internal flash. That solved the issue. None of the sensors lost their firmware since...

Return to “SAM D20 Cortex-M0+ MCU”

Who is online

Users browsing this forum: No registered users and 1 guest