Page 1 of 1

eMMC 5.1 Compatibility

Posted: Mon Jun 04, 2018 11:20 am
by pasnew
Hi,
Since I don't have the required permissions to read topics on the product section, I post my question here.

I'm going to design a custom SAMA5D24 board with a eMMC as boot device, since most eMMC 4.51 chips are in NRND status, I'd like to know if eMMC 5.1 chips like EMMC04G-M627 & SDINBDG4-8G are bootable.

According to eMMC specification it seems backward compatibility is possible, could someone give me a confirmation ?

Thanks,

Re: eMMC 5.1 Compatibility

Posted: Fri Jun 08, 2018 12:40 am
by blue_z
pasnew wrote:According to eMMC specification it seems backward compatibility is possible
Not just "seems ... possible", but actually stated. Why are you so skeptical?
If you want to be a pessimist, then anything you design/build might not work in spite of "confirmations".

See slide 5 of this presentation on the major differences of recent eMMC specs, and Designing for Flexibility around eMMC.

FWIW the datasheet for the EMMC04G-M627 explicitly claims compatibility with a list of eMMC specification versions.

Regards

Re: eMMC 5.1 Compatibility

Posted: Thu Jun 14, 2018 12:40 pm
by pasnew
Thanks for your reply.

I post my question here is NOT because I can't read, just because i.MX of NXP can't boot from eMMC 5.0/5.1 according to their official statement: https://community.nxp.com/docs/DOC-332187

Here with SAMA5 we are in the same situation.

Regards

Re: eMMC 5.1 Compatibility

Posted: Thu Jun 14, 2018 8:54 pm
by blue_z
Since eMMC 5.0/5.1 does not use a 3.3V interface, this recent post may be salient to you: viewtopic.php?f=30&t=26957

Regards