Page 1 of 1

SAM4E GMAC "No Broadcast" flag doesn't filter

Posted: Tue Nov 14, 2017 8:20 pm
by vlotech
To optimize the processing power of the SAM4E, I would like to block all broadcast messages.

I've enabled the flag at initialization of the GMAC, but broadcast messages are still coming through.

The MCU is running eCOS and LWIP.

Any ideas? Perhaps it's not implemented (as some parts of the PTP are missing too)

Re: SAM4E GMAC "No Broadcast" flag doesn't filter

Posted: Tue Nov 14, 2017 9:34 pm
by tsvoipio
If your Ethernet is in a TCP/IP network, please think twice before disabling Ethernet broadcasts. It will kill ARP and your node will be practically invisible in the network.

--

-TV