SAM4S power question

Discussion around product based on ARM Cortex M4 core.

Moderators: nferre, ncollot

Lt_Flash
Posts: 7
Joined: Tue Jun 10, 2014 6:41 am

SAM4S power question

Fri Jul 24, 2015 11:27 am

Hi,
I've implemented a board that uses a SAM4S MCU with a backup battery and found strange issue with it. As per datashit, I've got two diodes on VDDIN+VDDIO lines supplying MCU with either 3V3 from voltage regulator or 3V from battery. Also I have TWI bus connected with pullups to 3V3 line, plus SWD lines are connected to 3V3 using pullups as well. Another line connected is PB5, again - with pullup to 3V3 from regulator, that one is used as a regulator voltage sense port. I've reconfigured that port using MATRIX to be just PB5, not JTAG line.

So, when I don't have any diode connected the MCU should not be coming up, as there's no VDDIN/VDDIO voltage present due to the lack of diode. But, for some reason, MCU comes up and starts working as usual and I can see about 2.3 Volts on VDDIN/VDDIO lines! I can't figure out why is that happening? The only idea I have is that the MCU somehow picks up voltage from SWD/TWI buses and uses that to power up internal voltage regulator, but the current is very low so I can see only about 2.3 Volts on VDDIO lines. Have anyone else experienced such behaviour? Any help would be much appreciated.
Lt_Flash
Posts: 7
Joined: Tue Jun 10, 2014 6:41 am

Re: SAM4S power question

Fri Jul 24, 2015 11:28 am

For some reason I'm unable to attach my schematic and PCB layout, I'm getting 'Sorry, the board attachment quota has been reached.' error :(
Lt_Flash
Posts: 7
Joined: Tue Jun 10, 2014 6:41 am

Re: SAM4S power question

Sun Jul 26, 2015 1:28 pm

Thanks, I'll try to, but anyway - the only lines that are connected to 3V3 are SWD/TWI and PB5, so I probably just need to try to unsolder pullup resistors from these and see if MCU still powers up. I don't see any other issues with my schematic/PCB but that's a really strange behaviour.
Lt_Flash
Posts: 7
Joined: Tue Jun 10, 2014 6:41 am

Re: SAM4S power question

Sat Dec 19, 2015 2:52 am

Maybe this will help someone. Answering my own question - yes, MCU can be powered up via ANY pin because of the ESD protection diodes. So, in my case these pins were TWD/TWCK and SWDIO/SWDCK. And here's a great video on why is it happening.

https://www.youtube.com/watch?v=2yFh7Vv0Paw

Return to “SAM4 Cortex-M4 MCU”

Who is online

Users browsing this forum: No registered users and 1 guest