2.3.5 Android works fast. (9G15-EK)

This forum is for users of Microchip MPUs and who are interested in using Android.

Moderator: nferre

okida
Posts: 29
Joined: Tue May 22, 2012 10:19 pm

2.3.5 Android works fast. (9G15-EK)

Tue Jul 03, 2012 8:24 am

Hi readers.
I have 9G15-EK board. And i've compiled, Bootstrap, Uimage, Android FS and User Data. And i flashed it. All are working now.

But I noticed that there is time drift on System Clock. Almost 1.25seconds/hr. Also i installed my android application which count 10mSecs interval. It works faster than PC's Virtual Machines's One.

My project is standalone project and i can't connect internet. So i can't correct time problem. However it isn't a resolve. Clock works fast.
Is there any idea.?

Thanks
Embest
Contact:
Location: Shenzhen, China
Posts: 62
Joined: Tue Jun 08, 2004 3:29 am

Re: 2.3.5 Android works fast. (9G15-EK)

Wed Jul 04, 2012 5:02 am

9G15-EK was not tested yet,The demo code runs Ok on our tested boards:sam9m10-ek , sam9x5-ek sam9g45-ek
okida
Posts: 29
Joined: Tue May 22, 2012 10:19 pm

Re: 2.3.5 Android works fast. (9G15-EK)

Thu Jul 05, 2012 7:54 am

Thanks for reply.
In fact i used 9x5 files for everything. I wasn't able to find direct 9g15 file for anything.

My Android Java project uses an animation. A propeller rotating with 3 frame and duration is 100mSeconds. It seems okay on PC's AVD. But on Kit Side, anybody can sense the different.

Also this problem effected on RTC. However. This is just warning for my project.

Many Thanks

Return to “ANDROID”

Who is online

Users browsing this forum: No registered users and 1 guest