SAM-9G15, NAND Flash and DEMO BIN's

This forum is for users of Microchip MPUs and who are interested in using Android.

Moderator: nferre

okida
Posts: 29
Joined: Tue May 22, 2012 10:19 pm

SAM-9G15, NAND Flash and DEMO BIN's

Fri Jun 15, 2012 8:03 am

Hi all.
This is my first time with an embedded OS. I have a problem with NAND Flash booting.
Sometimes when i power-up the board from NAND, the booting operation interrupted by system. It isn't able to pass UBIFS installation phase. Due to "ubi_io_read: error -1".
Also i wasn't able to install an APK file from ADB bridge. it gives "INSTALL_FAILED_CONTAINER_ERROR". I think system works on FLASH chip and it can't do anything of course. But is there anyway to install an APK to NAND based system?
Also when the system booting correctly, first usable screen comes about 2minutes. It takes too long.

So, In SD-Card side everything is okay for me. It works pretty good. I was able to .APK files. And they worked good.

Do you have any idea about my NAND Flash problems.?

"By the way, i remembered that; when i first powerd-up the board (first time) which its native OS linux, it was worked good from NAND. But i should use Android."

Many Thanks
okida
Posts: 29
Joined: Tue May 22, 2012 10:19 pm

Re: SAM-9G15, NAND Flash and DEMO BIN's

Mon Jun 18, 2012 11:50 am

I've just resolved.

In SAM-BA, the TCL file didn't work properly. So i had decided to do step by step like TCL file does. But i passed "trimffs". This is the reason why i gave many problem about memory and UBIFS. I discovered that trimffs is selectable on PMECC Config menu. And I tried again with trimffs setting. All are working good.

Return to “ANDROID”

Who is online

Users browsing this forum: No registered users and 1 guest