SAM-BA no valid processor id

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

steve_mowbray@hotmail.com
Location: Ullapool
Posts: 10
Joined: Thu Feb 14, 2008 5:11 pm

SAM-BA no valid processor id

Wed Feb 20, 2008 4:07 pm

I have a new AT91SAM7S256-EK which to my knowledge has not been reprogrammed or jumpers altered from the factory default setting but I am unable to get SAM-BA to connect through the SAM-ICE JTAG pod. I have read the similar recent posts but I am still confused as they dont seem to apply in my case. Is there a missing SAM-BA command line option or some script file that needs to be patched after ISP installation to get the board/processor recognised?

using AT91SAM7S256-EK with SAM-ICE jtag pod and following the "Using Open Source Tools for AT91SAM7S Cross Development" tutorial Eclipse (YAGARTO) gives the following console output:

-I- Waiting ...
connection : \jlink\ARM0
board : AT91SAM7S256-EK
target(handle) : 22891232
read chip ID : 0x0012ED84 at addr: 0xFFFFEE40
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFEE40
read chip ID : 0x0012ED84 at addr: 0xFFFFEE40
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240
read chip ID : 0x0012ED84 at addr: 0xFFFFF240

any help will be much appreciated
Thanks
Steve
steve_mowbray@hotmail.com
Location: Ullapool
Posts: 10
Joined: Thu Feb 14, 2008 5:11 pm

recovery procedure not worked

Thu Feb 21, 2008 2:48 pm

situation worse now after trying the recovery procedure SAMBA now reports J-Link ARM Error - Unable to halt ARM core / CPU not halted followed by the no valid processor id message...

from the manual:

On AT91SAM7S-EK Evaluation Kit

SAM-BA Boot is stored in a ROM not accessible to the user. However, it is possible to recover SAM-BA Boot when needed.

To recover SAM-BA Boot on an AT91SAM7S-EK Evaluation Board, proceed that way:

1. Power Off the board.
2. Close JP5 jumper or set TST pin to high level.
3. Power On the board.
4. Wait about 10 seconds
5. Power Off the board.
6. Open JP5 jumper or set TST pin to ground.
7. Power On the board.

SAM-BA Boot is now loaded on the target. An application can then be loaded into the Flash memory.
steve_mowbray@hotmail.com
Location: Ullapool
Posts: 10
Joined: Thu Feb 14, 2008 5:11 pm

Fri Feb 22, 2008 4:59 pm

solved thanks to atmel support (http://support.atmel.no).

sam-ice firmware needed updating - I ran segger jlink arm v3.78d utility called jlink.exe which appears to automatically check and update the the jtag pod firmware. Not sure if this is the prescribed method but it worked and I now have samba connection through the sam-ice port.

Hope this helps somebody
sjremya
Posts: 12
Joined: Thu Sep 09, 2010 2:42 pm

Re: SAM-BA no valid processor id

Fri Sep 17, 2010 12:07 pm

Hi

I have same kind of problem with SAM_BA v2.8 & AT91SAM9260-ek.

I have tried with USB & serial connections. Its throwing me error "No valid processor ID found"

I do not have emulator. So only option is USB/serial connector.

Please help me out

Regards
SJR

Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 2 guests