Page 1 of 1

[SAM-V71] SAM-BA under (Arch) Linux

Posted: Fri Jul 12, 2019 12:03 pm
by blietaer
Dear Community,



I am starting development on SAM E70/V71 chipset, using both the SAM V71 Xplained Ultra and the MCLV-2 (Motor) dev. kits.

We do have a SAM-ICE (SEGGER JLink) debugger (JTAG/SWD) but I kind of want to stick to sam-ba flash for quick 'blinking LEDs' tests...in the idea to have the sam-ba CLI part of my makefile, so I can do 'make/make install', in a kind of arduino-like approach, but without any IDE involved, of course.



I managed to have it working once through the sam-ba (USB on target port), and could see the new behavior of the LED/board.

Then, following the manual, I closed the ERASE pin, powered it on, waited for it to complete (how to know?!) and then reopen the jumper and power it back on.

However, I can't manage to see the /dev/ttyACM0 port anymore... (nor in dmesg nor in /dev/, tried different USB cables)



So, questions:

a.) is that the case that sam-ba is meant to be used _without_ SAM-ICE debugger being plug at all?

b.) are you guys enthusiasts of sam-ba or always using the SAM-ICE, even when no debugging activity involved? do you recommend it ? or too unstable?

c.) could the sam-ba bootloader be actually damaged/erased in the board's ROM? if so, is there a procedure to reinstall/activate the sam-ba bootloader?

d.) What is the actual complete procedure to hook the board in sam-ba? on PC/Linux side? on the board side? does it involve anything else than the ERASE jumper? buttons? debug USB port?

e.) is that correct the latest version of sam-ba (3.2.3 in AUR) does not support GUI anymore?



Thank you for your answers/hints/comments/links,



Kind regards,

Cheers,

Ben