SAM-BA 2.15 Hangs after identifying board

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

TheBurrito
Posts: 1
Joined: Sat Apr 25, 2015 5:45 am

SAM-BA 2.15 Hangs after identifying board

Sat Apr 25, 2015 6:02 am

Code: Select all

-I- Waiting ...
-I- TCL platform : Linux
-I- SAM-BA CDC 2.15  on : linux
-I- Retrieved arguments from command line :
-I- argv 0 : /dev/ttyUSB0
-I- argv 1 : at91sam4n16-xpro
-I- argv 2 : 
-I- Connection /dev/ttyUSB0
-I- Connection : /dev/ttyUSB0 (target(comType) = 0)
-I- Board : at91sam4n16-xpro
-I- Traces Level : 4
-I- target(handle) : file5
-I- sourcing board description file /home/derrick/dev/sam-ba_cdc_linux/tcl_lib/at91sam4n16-xpro/at91sam4n16-xpro.tcl
Read device Chip ID at 0x400E0740 --- get 0x29560ce0
-I- Found chip : at91sam4n16_1 (Chip ID : 0x29560ce0)
-I- Loading applet applet-lowlevelinit-sam4n16.bin at address 0x20001000
I have erased the flash with the erase test pad on the xplained pro board but I am not ever able to get into SAM-BA it seems. Any ideas?

Edit: on another run it stops at the sourcing board description file line.

Edit edit: SAM-BA on windows is able to open up and read the chip's memory.
lcox@landoncox.com
Posts: 2
Joined: Thu Dec 17, 2015 12:02 am

Re: SAM-BA 2.15 Hangs after identifying board

Thu Dec 17, 2015 12:19 am

I am having an identical problem, however, my Windows system cannot get by this either and reports via a popup dialog that the applet never returns.

This happens when I run the demo script:

Code: Select all

./demo_linux_nandflash.sh
-I- Waiting ...
-I- TCL platform : Linux
-I- SAM-BA CDC 2.15  on : linux
-I- Retrieved arguments from command line :
-I- argv 0 : /dev/ttyACM0
-I- argv 1 : at91sama5d4x-ek
-I- argv 2 : demo_linux_nandflash.tcl
-I- Connection /dev/ttyACM0
-I- Connection : /dev/ttyACM0 (target(comType) = 0)
-I- Board : at91sama5d4x-ek
-I- Traces Level : 4
-I- target(handle) : file5
-I- sourcing board description file /home/lcox/sama5d4/sam-ba_cdc_linux/tcl_lib/at91sama5d4x-ek/at91sama5d4x-ek.tcl
Read device Chip ID at 0xFC069040 --- get 0xffffffff8a5c07c0
-I- Found chip : at91sama5d4x_0 (Chip ID : 0xffffffff8a5c07c0)
-I- Loading applet applet-lowlevelinit-sama5d4x.bin at address 0x200000
^C
I'm using the sam-ba_64 on Ubuntu. I am able to screen to /dev/ttyACMO, jumper the the boot_dis pins, then reset and see the string "BootROM". I get out of screen and then invoke the script or sam-ba_64.

Were you able to find a solution to this issue? Or does anyone else know why it would hang here?
blue_z
Location: USA
Posts: 1560
Joined: Thu Apr 19, 2007 10:15 pm

Re: SAM-BA 2.15 Hangs after identifying board

Fri Dec 18, 2015 12:00 am

Is this EK board powered by a wall-wart or just through USB?

Regards
lcox@landoncox.com
Posts: 2
Joined: Thu Dec 17, 2015 12:02 am

Re: SAM-BA 2.15 Hangs after identifying board

Wed Jan 13, 2016 6:17 pm

Thanks for the reply, for some reason I didn't get notification of it. The answer is USB only.

I surmise you're thinking I should use an external power source.
blue_z
Location: USA
Posts: 1560
Joined: Thu Apr 19, 2007 10:15 pm

Re: SAM-BA 2.15 Hangs after identifying board

Wed Jan 13, 2016 10:19 pm

lcox@landoncox.com wrote:I surmise you're thinking I should use an external power source.
Yes. Apparently the Xplained boards can run off just USB power, but not the big EK boards.
  • 1. Apply external +5VDC.
    2. Disable flash chip selects, e.g. remove jumpers and/or hold-down push-button. Remove any SDcards
    3. press&release reset button. (If you have a DBGU connection, you should see a "RomBOOT" and nothing else.)
    4. restore chip selects, e.g. install jumpers and/or release push-button.
    5. connect target's USB Device port to host PC.
    6. execute SAM-BA on host.
Regards

Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 1 guest