AT45DB642D Replacement with AT45DB641E

ATMEL in-system programing solution including SAM-BA and SAM-PROG.

Moderators: nferre, fab

siddaram
Posts: 1
Joined: Sat Nov 08, 2014 6:27 am

AT45DB642D Replacement with AT45DB641E

Sat Nov 08, 2014 6:40 am

Hi,

We are using AT91SAM9260 Atmel microcontroller which uses AT45DB642D(Adesto technologies part) as Dataflash. But recently AT45DB642D got obsolete. Replacement part suggested is AT45DB641E.

We observed following differences between two chips
1)Number of Bytes in a page
264 bytes per page (default for AT45DB641E) ,1056 bytes per page (default for AT45DB642D)

2)Number of pages
32768 for AT45DB641E, 8192 for AT45DB642D


We have done following changes
1)We got samples of AT45DB641E and done following changes in SAM BA Ver 2.9 applet

Updated the at45Devices[] table present at45.C by adding the following line and Compiled:

32768, 1, 264, 11, 0x3C, AT45DB641E

Result: Comparison of sent & Target Memory didn't match in Samba

2) We changed AT91SAMBootstap code in following files.

i) Updated AT45DB641E case statement in Dataflash.C from Driver folder
ii) Defined AT45DB641E as 0x3C Dataflash.h from Include folder

Result: Comparison of sent & Target Memory didn't match in Samba

So, please Guide us where we are going wrong. As we are new to Atmel Microcontrollers
FredrikT
Posts: 1
Joined: Fri Jan 23, 2015 12:13 pm

Re: AT45DB642D Replacement with AT45DB641E

Fri Jan 23, 2015 12:19 pm

I am working with the same issue. We got information from adesto (I have a zip file i can share ). I have succesfully updated samba. But now i am working with the AT91Bootstrap1.6 and i have got it to find the memory AT45DB641E but when i try to go futher the bootstrap just reboots.

have anyone suffered the same problems?
jagannatharaok
Posts: 4
Joined: Mon Aug 29, 2011 10:37 am

Re: AT45DB642D Replacement with AT45DB641E

Wed Feb 04, 2015 7:01 am

please refer this link

http://atmel.force.com/support/articles ... tedArticle

make the following changes w.r.t link

point 2, use 9 instead of 11
point 8, use 0x3C only

it worked for me
TimH
Posts: 1
Joined: Tue Sep 03, 2013 1:54 am

Re: AT45DB642D Replacement with AT45DB641E

Tue Mar 15, 2016 7:23 pm

Sorry to re-open a thread, but I have just had 100 boards manufactured with the AT45DB641E in place of the 642D, and have modified the code as per guidance, and tried the changes suggested here. Processor is SAM9261

27 of the 100 boards report back as having the old 642D device not the new 641E device. The devices are marked correctly, will not program via SAM-BA (as it thinks they are 642D devices).

I have done some minimal debugging and the 4th byte is not coming back as 0x01, so it is deciding the device is the 642D.

That said, if I force the check of the 4th byte to be true, the debug port, when running SAM-BA, it comes back with "device unknown"...so maybe this is a sign of faulty board manufacture.

I will try debugging this further, but has anyone seen this? Are there any known issues with the 641E device?

Return to “AT91-ISP”

Who is online

Users browsing this forum: No registered users and 1 guest