SAM-BA v2.12 : Cannot "Enable NandFlash"

ATMEL in-system programing solution including SAM-BA and SAM-PROG.

Moderators: nferre, fab

kimi
Posts: 5
Joined: Tue Dec 24, 2013 2:36 pm

SAM-BA v2.12 : Cannot "Enable NandFlash"

Fri May 23, 2014 5:02 pm

Hello Everyone,

I just receive 4 boards designed basing on the AT91SAM9G45-EKES. Their core part is the same as the AT91SAM9G45-EKES.

One of them just can't be programmed by SAM-BA. It failed at the initialization of the NandFlash.

Here is the logfile:

Code: Select all

-I- Found processor : at91sam9g45 (Chip ID : 0x819b05a2)
sourcing device file C:/Program Files/Atmel/sam-ba_2.12/sam-ba.exe/../tcl_lib/devices/at91sam9g45.tcl
sourcing board description file C:/Program Files/Atmel/sam-ba_2.12/sam-ba.exe/../tcl_lib/at91sam9m10-ek/at91sam9m10-ek.tcl
-I- Loading applet applet-lowlevelinit-at91sam9m10.bin at address 0x308000
-I- Memory Size : 0x2 bytes
-I- Buffer address : 0x4
-I- Buffer size: 0x0 bytes
-I- Applet initialization done
-I- Low level initialized
-I- External RAM Settings :  extRamVdd=0, extRamType=1, extRamDataBusWidth=16, extDDRamModel=0
-I- Loading applet applet-extram-at91sam9m10.bin at address 0x308000
-I- Memory Size : 0x8000000 bytes
-I- Buffer address : 0x3094DC
-I- Buffer size: 0x0 bytes
-I- Applet initialization done
-I- External RAM initialized
-I- Command line mode : Execute script file : at91sam9g45ekes_demo_linux_nandflash.tcl
-I- === Initialize the NAND access ===
-I- NANDFLASH::Init (trace level : 4)
-I- Loading applet applet-nandflash-at91sam9m10.bin at address 0x70000000
-E- Script File at91sam9g45ekes_demo_linux_nandflash.tcl returned error : Applet Init command has not been launched (-E- Timeout: The applet did not return. 
Please check the connection and reconnect the target device.) - Applet Init command has not been launched (-E- Timeout: The applet did not return. 
Please check the connection and reconnect the target device.)
    while executing
"error "Applet Init command has not been launched ($dummy_err)""
    (procedure "GENERIC::Init" line 42)
    invoked from within
"GENERIC::Init $NANDFLASH::appletAddr $NANDFLASH::appletMailboxAddr $NANDFLASH::appletFileName [list $target(comType) $target(traceLevel)]"
    (procedure "NANDFLASH::Init" line 11)
    invoked from within
"NANDFLASH::Init"
    (file "at91sam9g45ekes_demo_linux_nandflash.tcl" line 91)
    invoked from within
"source $scriptFile"
I get in the SAM-BA GUI to try to do it manually and then find that it's not only the NandFlash, but also the DataFlash (AT45DB), the EEPROM (AT24C512) can't be "Enabled" either. They got the same error message as below:

Image

I guess it should be a hardware issue (component, manufacturing etc.) as the others just work fine. But I don't know it could be which part of the circuit because all of these storage devices are affected.

Could you please help me ?

Thanks a lot.
Attachments
nom20140523165645.png
nom20140523165645.png (11.94 KiB) Viewed 15771 times
smart
Posts: 16
Joined: Sat Dec 31, 2016 10:42 am

Re: SAM-BA v2.12 : Cannot "Enable NandFlash"

Wed Jan 04, 2017 3:55 am

kimi wrote:Hello Everyone,

I just receive 4 boards designed basing on the AT91SAM9G45-EKES. Their core part is the same as the AT91SAM9G45-EKES.

One of them just can't be programmed by SAM-BA. It failed at the initialization of the NandFlash.

Here is the logfile:

Code: Select all

-I- Found processor : at91sam9g45 (Chip ID : 0x819b05a2)
sourcing device file C:/Program Files/Atmel/sam-ba_2.12/sam-ba.exe/../tcl_lib/devices/at91sam9g45.tcl
sourcing board description file C:/Program Files/Atmel/sam-ba_2.12/sam-ba.exe/../tcl_lib/at91sam9m10-ek/at91sam9m10-ek.tcl
-I- Loading applet applet-lowlevelinit-at91sam9m10.bin at address 0x308000
-I- Memory Size : 0x2 bytes
-I- Buffer address : 0x4
-I- Buffer size: 0x0 bytes
-I- Applet initialization done
-I- Low level initialized
-I- External RAM Settings :  extRamVdd=0, extRamType=1, extRamDataBusWidth=16, extDDRamModel=0
-I- Loading applet applet-extram-at91sam9m10.bin at address 0x308000
-I- Memory Size : 0x8000000 bytes
-I- Buffer address : 0x3094DC
-I- Buffer size: 0x0 bytes
-I- Applet initialization done
-I- External RAM initialized
-I- Command line mode : Execute script file : at91sam9g45ekes_demo_linux_nandflash.tcl
-I- === Initialize the NAND access ===
-I- NANDFLASH::Init (trace level : 4)
-I- Loading applet applet-nandflash-at91sam9m10.bin at address 0x70000000
-E- Script File at91sam9g45ekes_demo_linux_nandflash.tcl returned error : Applet Init command has not been launched (-E- Timeout: The applet did not return. 
Please check the connection and reconnect the target device.) - Applet Init command has not been launched (-E- Timeout: The applet did not return. 
Please check the connection and reconnect the target device.)
    while executing
"error "Applet Init command has not been launched ($dummy_err)""
    (procedure "GENERIC::Init" line 42)
    invoked from within
"GENERIC::Init $NANDFLASH::appletAddr $NANDFLASH::appletMailboxAddr $NANDFLASH::appletFileName [list $target(comType) $target(traceLevel)]"
    (procedure "NANDFLASH::Init" line 11)
    invoked from within
"NANDFLASH::Init"
    (file "at91sam9g45ekes_demo_linux_nandflash.tcl" line 91)
    invoked from within
"source $scriptFile"
I get in the SAM-BA GUI to try to do it manually and then find that it's not only the NandFlash, but also the DataFlash (AT45DB), the EEPROM (AT24C512) can't be "Enabled" either. They got the same error message as below:

Image

I guess it should be a hardware issue (component, manufacturing etc.) as the others just work fine. But I don't know it could be which part of the circuit because all of these storage devices are affected.

Could you please help me ?

Thanks a lot.
my problem is just the sam with you do you solved ?
e-mail:925295580@qq.com

Return to “AT91-ISP”

Who is online

Users browsing this forum: No registered users and 1 guest