Problem with SAM-BA and only an ATSAM3U1C

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

Mark Bongers
Posts: 7
Joined: Thu Apr 27, 2006 2:54 pm

Problem with SAM-BA and only an ATSAM3U1C

Wed Jan 12, 2011 12:04 pm

Hi,

I only need to use SAM-BA with an ATSAM3U1C to program the internal flash memory, since my own board only contains an ATSAM3U1C controller. I tried to use the SAM3U1-EK with SAM-BA CDC 2.10, but the program just hangs. Can someone help me with a simple script just to flash the internal flash of the ATSAM3U1C processor?
Thanks in advance.

Mark.
CptTitanic
Posts: 877
Joined: Sat Oct 30, 2010 6:04 pm

Re: Problem with SAM-BA and only an ATSAM3U1C

Thu Jan 13, 2011 5:12 am

My familiarity is with AT91 parts in general, rather than the SAM3, so I'll throw some general thoughts in here.

I'll assume the SAM3U1-EK option was from the SAM-BA menu, rather than an actual SAM3U1-EK board in your possession.

Do you have a SAM3U1-EK board you can try?

Are you sure your part/board is viable at this point? If you are trying to bring up a new board, you should probably double check the voltages, and frequencies, and general responsiveness at start up.

What other components or circuitry is connected to your part?

Are you trying to connect via USB, Serial or JTAG?

Try a JTAG/SWD connection for SAM-BA, using a SAM-ICE or J-LINK. Or use Segger's
J-LINK application to see if it can see/use the SAM3 part.

Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 1 guest