AT91 SAM-BA with USB stop working after AT91-ICE connected

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

prinzenrolle
Posts: 38
Joined: Mon Jul 05, 2010 8:10 am

AT91 SAM-BA with USB stop working after AT91-ICE connected

Tue Aug 03, 2010 10:06 pm

Hello,
today i ve test my new AT91SAM-ICE JTAG http://atmel.com/dyn/products/tools_car ... ol_id=3892
with the at91sam9g45-ekes

But now the USB \usb\ARM0 with SAM-BA doesnt work anytime. I test the board AT91SAM9G45-EKES also on an other pc the same error....

what have i damaged or deleted on the board?
i test it also with the sam-ba gui deleting and erasing the nand works but writing an file into the nand is the result allways the same samba crashs.
but with (jtag) at91sam-ice it works.
LOG:

Code: Select all

-I- Waiting ...
-I- TCL platform : Windows NT
-I- SAM-BA 2.9  on : windows
-I- Retrieved arguments from command line :
-I- argv 0 : \usb\ARM0
-I- argv 1 : AT91SAM9G45-EK
-I- argv 2 : at91sam9g45ekes_demo_linux_nandflash.tcl
-I- Connection : \usb\ARM0 (target(comType) = 0)
-I- Board : at91sam9g45-ek
-I- Traces Level : 4
-I- target(handle) : 18015848
Read device Chip ID at 0xfffff240 --- get 0x00000000
Read device Chip ID at 0xffffee40 --- get 0x819b05a2
-I- Found processor : at91sam9m10 (Chip ID : 0x819b05a2)
-I- External RAM Settings :  extRamVdd=0, extRamType=1, extRamDataBusWidth=16, extDDRamModel=0
-I- Loading applet isp-extram-at91sam9g45.bin at address 0x308000
-I- Memory Size : 0x8000000 bytes
-I- Buffer address : 0x3095A4
-I- Buffer size: 0x0 bytes
-I- Applet initialization done
-I- External RAM initialized
-I- Command line mode : Execute script file : at91sam9g45ekes_demo_linux_nandflash.tcl
-I- === Initialize the NAND access ===
-I- NANDFLASH::Init (trace level : 4)
-I- Loading applet isp-nandflash-at91sam9g45.bin at address 0x70000000
-I- Memory Size : 0x10000000 bytes
-I- Buffer address : 0x70003BE8
-I- Buffer size: 0x20000 bytes
-I- Applet initialization done
-I- === Erase all the NAND flash blocs and test the erasing ===
-I- GENERIC::EraseAll
-I- === Load the bootstrap: nandflash_at91sam9-ek in the first sector ===
GENERIC::SendFile nandflash_at91sam9g45ekes.bin at address 0x0
-I- File size : 0x1410 byte(s)
-I- 	Writing: 0x1410 bytes at 0x0 (buffer addr : 0x70003BE8)
plz help me
prinzenrolle
Posts: 38
Joined: Mon Jul 05, 2010 8:10 am

Re: AT91 SAM-BA with USB stop working after AT91-ICE connected

Wed Aug 04, 2010 10:51 am

Hello,
i installed Samba V2.10 on an XP Machine and it works.

So i ve deinstalled AT91-ISP 1.13 and Samba V2.09 on my workstation (vista) and installled Samba V2.10

but the samba cdc edition wont open,
the com driver is installed and displayed in the hardware manager (com7)

some hints?

Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 2 guests