Page 1 of 1

SAM-BA and Windows 7 32 bit

Posted: Thu Apr 15, 2010 6:46 pm
by palsson
Hi there

Running SAM-BA on my Windows 7 machine is not a success.
I just upgraded from XP with nicely working setup... shouldn't have!

I'm playing with the AT91SAM9RL64 evaluation kit.
When connecting USB, Windows 7 finds and links a GPS Camera driver which is a virtual com port and not a cdc as with XP.

Running the SAM-BA *.exe the connection window appears, where I can select the com port and the evaluation kit. After that, the execution fails with a script error not able to set comm state, etc.

Anyone else experienced the same?

Regards
palsson

Re: SAM-BA and Windows 7 32 bit

Posted: Wed Apr 21, 2010 11:01 am
by kewxke
Currently, the SAM-BA for windows7 is not released yet. But someone said that he could use while some couldn't. For your issue, please have a look at the FAQ http://support.atmel.no/bin/customer?=& ... try&id=678.

Re: SAM-BA and Windows 7 32 bit

Posted: Wed Apr 21, 2010 9:23 pm
by palsson
Hi there

Thanks for your reply.
Ok, so the Vista version of SAM-BA is not compatible for Windows 7 or...?

/palsson

Re: SAM-BA and Windows 7 32 bit

Posted: Sun May 02, 2010 9:54 am
by DonkeyDave
I'm using SAM-BA on Win7 32bit and experienced the same problem with the GPS Camera. If you uninstall the GPS camera in device manager (and select to delete drivers) then switch off your internet connection so that windows can't look at windows update for the driver.

Unplug/re-plug your device then point to the SAM-BA inf file. You can now reconnect your internet connection and have a SAM-BA party...

Re: SAM-BA and Windows 7 32 bit

Posted: Sun May 02, 2010 6:25 pm
by palsson
Hello Dave

Thanks for the tip.
I managed to get passed the GPS camera driver, and install the atm6124_cdc.inf driver for the SAM-BA. I'm trying with SAM-BA 2.9 by the way.

"AT91 USB to Serial Converter" gets installed, and I get a COM port registered again, instead of the usb driver. When I execute SAM-BA and try to connect using the COM port, I get an "Error in startup script".

Re: SAM-BA and Windows 7 32 bit

Posted: Fri May 14, 2010 11:48 am
by palsson
Hi there

Just reporting my working SAM-BA on Windows 7.
By installing AT91-ISP package v1.13 I was able to follow the procedure introduced before by donkeydave.

Before I had downloaded SAM-BA itself, not the ISP package, and for some reason that package was not containing the drivers needed.

Anyways.. I'm having a SAM-BA party!

Regards
palsson

Re: SAM-BA and Windows 7 32 bit

Posted: Wed Aug 25, 2010 8:56 am
by kosh
Morning,

im using SAM-BA v2.10 and Segger JLINK and it appears that in Windows 7 only the CDC Version got installed. This does not support JLINK (in my case...)

Solve:

Start the Installer in Windows XP Mode and you get to choose the "normal" Installation of both Versions

And better than in 2.9, SAM-BA save your favoured board