SAM-BA 2.9 and SAM9G45

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

User avatar
pma
Contact:
Location: Burnaby, BC, Canada
Posts: 13
Joined: Fri May 18, 2007 12:15 am

SAM-BA 2.9 and SAM9G45

Sat Sep 12, 2009 8:19 am

I have a custom AT91SAM9G45 (-ES, date code 0924) board that I am trying to get SAM-BA working with, over AT91SAM-ICE.
I took the AT91SAM9G45-EK tcl scripts, and disabled everything except internal SRAM, peripherals, etc. I am using LPDDR SDRAM, so dealing with that will come later.
When I launch SAM-BA 2.9, select \jlink\ARM0 and the modified board, I get the following error dialog:
"No valid processor ID found"

Using Segger's J-Link Commander:

Code: Select all

SEGGER J-Link Commander V4.08k ('?' for help)
Compiled Aug 18 2009 09:41:04
DLL version V4.08k, compiled Aug 18 2009 09:40:47
Firmware: J-Link ARM V8 compiled Aug 18 2009 09:06:07
Hardware: V8.00
S/N : 28002928
OEM : SAM-ICE
Feature(s) : RDI
VTarget = 3.339V
Info: TotalIRLen = 4, IRPrint = 0x01
Info: CP15.0.0: 0x41069265: ARM, Architecure 5TEJ
Info: CP15.0.1: 0x1D192192: ICache: 32kB (4*256*32), DCache: 32kB (4*256*32)
Info: Cache type: Separate, Write-back, Format C (WT supported)
Found 1 JTAG device, Total IRLen = 4:
 #0 Id: 0x0792603F, IRLen:  4, IRPrint: 0x0 ARM926EJ-S Core
Found ARM with core Id 0x0792603F (ARM9)
RTCK reaction time is approx. 189ns
Using adaptive clocking instead of fixed JTAG speed.
J-Link>i
JTAG Id: 0x0792603F  Version: 0x0 Part no: 0x7926 Man. Id: 001F
So the Mfg ID is 0x1f (Atmel), and the Part Number is 0x7926. This does not match with the latest 9G45 datasheet (should be 0x5B27).
Any idea what might be happening here?
Anny.Lee09
Posts: 21
Joined: Sat Aug 22, 2009 8:12 am

Re: SAM-BA 2.9 and SAM9G45

Mon Dec 21, 2009 7:00 am

You should open JP10 First,and you can also try using USB to connect the borad.
An RTOS specially for Cortex-M3----> http://www.coocox.org
velik
Posts: 23
Joined: Thu Jan 14, 2010 12:30 pm

Re: SAM-BA 2.9 and SAM9G45

Sun Mar 07, 2010 9:32 pm

Anny.Lee09 wrote:You should open JP10 First,and you can also try using USB to connect the borad.

I have ES2 board with 0942 code and it doesn't communicate via USB even with opened JP10. Via Serial communication I have a same Problem with "No valid processor ID found"

@ pma: If you realy have ES board try to use an algorithm described in Errata for this MCU:
http://www.atmel.com/dyn/resources/prod ... oc6485.pdf

In my case it doesn't work. Probably because I have ES2 and this errata is for ES.

Good luck and write here how you can resolve your problem :)
embestdevtools
Posts: 6
Joined: Fri Apr 02, 2010 5:08 am

A new ARM9 Evaluation Kit supporting Linux2.6.30 and WinCE6.

Tue Aug 31, 2010 10:00 am

There is an MBS-SAM9G45 Evaluation Kit which is also based on Atmel AT91SAM9G45 processor, it has followings features:
1) Composed of an SAM9G45 ARM9 Core Board and a full-featured Base Board which has plenty of peripherals and connectors.
2) With three kinds of TFT LCD Panel with touchscreen: 4.3", 7" and 10.2"
3) Pre-installed Linux2.6.30 OS on it, and is provided with BSPs for Linux2.6.30 and WinCE6.0 OS.

For more information about it, please refer to: http://www.samicc.com/2010/0807/mbs-sam9g45.html

Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 2 guests