Compiled applet (sdram) crashes AT91SAM9260

Microchip in-system programming solution: SAM-BA

Moderators: nferre, fab

AkkiSan
Posts: 2
Joined: Tue Aug 18, 2009 12:22 pm

Compiled applet (sdram) crashes AT91SAM9260

Tue Aug 18, 2009 11:43 pm

Hi all,

I have some custom boards, built around an AT91SAM9260, with M12L64164A and
MT48LC2M32B2 SDRAM.

As a solid basis, I used the AT91SAM9260-EK "settings".
I changed the sdram initialization in "board_memories.c" but the boards crash on
download.

After a few hours I decided to go back to the beginning:


a) a fresh, unchanged installation of sam-ba v2.9 (linux)

b) on startup (SAM9260-EK settings) sam-ba of course whines about a sdram init failure
=> but it does not lockup the CPU!

c) without making any changes to the code, I compiled the sdram init bin via:
make CHIP=at91sam9260 BOARD=at91sam9260-ek MEMORY=sdram_samba DYN_TRACES=1 INST_PREFIX=$ARGV[0] sdram
(I am using CodeSourcery arm-none-eabi, linux version)

d) on upload, the CPU locks up


So, is there something wrong with my arm toolchain?
Am >I< doing something complete wrong?

How can I debug this?
Would a kind of "hello pin" (derived from "hello world" ;-) application make sense?
I am not sure if the lockup is caused by

a) the download itself
b) a wrong code
c) a wrong SDRAM setting

I asume the latter won't lockup the CPU, right?
Otherwise the originally installed sam-ba version would lockup too, right?


Any (debugging) help is appreciated!

Thanks in advance
AS

Return to “SAM-BA”

Who is online

Users browsing this forum: No registered users and 1 guest