SAM-BA wont run under linux

Discussions about all user software around SAM Series.

Moderator: nferre

lachlanp
Posts: 27
Joined: Sun Jan 28, 2007 9:41 am

SAM-BA wont run under linux

Fri Sep 19, 2014 2:24 pm

I have loaded SAM-BA as per the Atmel website
linux4sam/bin/view/Linux4SAM/SoftwareTools
I have downloaded all the current software

I am using Ubuntu 14.04 with latest updates

When I try to run sam-ba I get an error

$ cd <sam-ba directory>
$ ls - l
-rwxr-xr-x  1 <user>  <user> 1799474 <date> sam-ba
$ sam-ba
No command 'sam-ba' found

Thank you for any ideas on what the problem could be
Lachlan
lachlanp
Posts: 27
Joined: Sun Jan 28, 2007 9:41 am

Re: SAM-BA wont run under linux

Fri Sep 19, 2014 2:54 pm

I have managed to get the program to execute by changing it to 
$ ./sam-ba
but when sam-ba runs it indicates that a number of files are missing.

sma-ba is loaded in the directory 
/home/../sam-ba_cdc_cdc_linux/

The errors look like this:
couldnt load file /home/../sam-ba_cdc_cdc_linux/sam-ba/lib/../libtk8.5.so : no such file or directory

and so on. 
The errors refer to files in a subdirectory called sam-ba, but there is no subdirectory of this name

Thank you for any ideas?
Lachlan
lachlanp
Posts: 27
Joined: Sun Jan 28, 2007 9:41 am

Re: SAM-BA wont communicate to board

Fri Sep 19, 2014 7:47 pm

I have solved the problem running sam-ba. I unzipped the file in Linux instead of windows and all is working.

However, I have problems communicating with the board.
I run sam-ba and it opens a dialog box called "sam-ba CDC2.1.2 patch7"
I select /dev/ttyUSB0 (default) and my board at91sama5d3x-ek and then connect, but it gives a communication error

I have done the following
$ sudo ln -s /dev /ttyACM0 /dev/ttyUSB0
plug in the SAMA5D36-EK
$ ls /dev
In ubuntu ttyUSB0 appears in blue
If i unplug the USB port ttyUSB0 goes red, so I presume the prot is working ok

Any ideas what could be causing a communication fault with the board?
Thanks
lachlanp
Posts: 27
Joined: Sun Jan 28, 2007 9:41 am

Re: SAM-BA wont run under linux

Fri Sep 19, 2014 7:55 pm

Extra information. On exit of sam-ba I get the following messages

Read device chip ID at 0xFFFFF240 --- get 0x66667720
Read device chip ID at 0xFFFFee40 --- get 0x32666666
Read device chip ID at 0x400e0640 --- get 0x342c3034
Read device chip ID at 0x400e0740 --- get 0x660a0d23
Read device chip ID at 0x400e0940 --- get 0x203e6666

Return to “Software”

Who is online

Users browsing this forum: No registered users and 1 guest