SAM-BA 2.12 does not display all COM ports

Discussions about all user software around SAM Series.

Moderator: nferre

kowalski5233
Posts: 6
Joined: Tue May 13, 2014 8:08 pm

SAM-BA 2.12 does not display all COM ports

Tue May 13, 2014 8:20 pm

Good day all.

We have SAM4L we want to bootload via SAM-BA over UART. The way our system is set up is with the UART going to another PCB with a PIC through which we will need to bootload the SAM4L by creating a pass-through on the PIC.
When doing this I can successfully communicate with the SAM over UART, so the system and setup has no problems.
The problem is that the SAM-BA 2.12 tool does not display the COM port that the connection is on. It does display COM3 which is a port my laptop's bluetooth opens. I moved the COM from COM17 to COM2 in case the tool does not like high value COM ports, but with no luck.
Some additional info, we use serial over USB to the PIC from the laptop. COM3 which the tool is pick up displays as 'Standard Serial over Bluetooth Link (COM3' and the connection to the PIC displays as 'USB Serial Port (COM2)'. There is also a COM11 which the tool does not pick up.
Any ideas?
kowalski5233
Posts: 6
Joined: Tue May 13, 2014 8:08 pm

Re: SAM-BA 2.12 does not display all COM ports

Sat May 17, 2014 1:19 pm

So in case someone else has this problem one day, we had to change the Vendor ID and Product ID of the PICs CDC to mimic that of the Atmels.

Now, the next SAM-BA hurdle...

Return to “Software”

Who is online

Users browsing this forum: No registered users and 1 guest