SAM-BA issues

Discussions about all user software around SAM Series.

Moderator: nferre

borisw37
Posts: 3
Joined: Mon Jul 01, 2013 4:39 pm

SAM-BA issues

Wed Oct 02, 2013 4:50 pm

I'm using SAM-BA V2.12 with Patch V4 on a windows XP machine, trying to program the SAM3U4-EK board.

SAM-BA seems to be very buggy and unstable.
I have gotten it to work but a lot of times after the initial screen and clicking "connect" the UI just disappears. The process "sam-ba.exe" is still running but nothing on the screen...
Other times I get an error "error in startup script"

Has anybody got SAM-BA to work reliably, or is there an alternative for USB programming of totally blank SAM3U devices?

Thank you,

Boris.
pgvoorhees
Posts: 1
Joined: Thu Apr 24, 2014 9:06 pm

Re: SAM-BA issues

Thu Apr 24, 2014 9:09 pm

I am having a similar issue, and am quite interested in hearing any ideas.

To add a few points, I've been able to get the board to respond to SAMBA commands on another computer, but on the computer in question, the device completely fails to respond to any commands. My suspicion is maybe a driver issue, though I am unable to make any headway beyond the instructions in the samba installation.

Thanks!
RGeels
Posts: 1
Joined: Fri May 23, 2014 1:42 am

Re: SAM-BA issues

Fri May 23, 2014 2:01 am

I have not been able to get SAM-BA to run any script. Here is what I tried:
1. Install latest version of SAM-BA (v2.12) for Windows in Windows 7-64bit.
2. Run Patch 6 to update SAM-BA.
3. Install CDC USB Driver.
4. Run SAM-BA.
5. Select connection (COM6) and board (at91sama5d3x-ek).
6. Click Connect.
7. In menu click Script File->Edit Script File...
8. Attempt to navigate to folder containing script.
An Error dialog appears before I can even open the file saying: Fatal Error in Wish - unable to realloc 130 bytes.

Please help. I can't Edit or Execute any script because I get this error message before I can even open the .tcl file.

Return to “Software”

Who is online

Users browsing this forum: No registered users and 1 guest