Problems with Optrex WVGA display on AT91SAM9263-EK board

This forum is for users of Atmel's SAM Series and who are interested in using µC/OS-II, The Real-Time Kernel.

Moderator: nferre

EricNH
Posts: 1
Joined: Fri Sep 11, 2009 7:55 pm

Problems with Optrex WVGA display on AT91SAM9263-EK board

Fri Sep 11, 2009 8:10 pm

I am having some problems adapting an Optrex T-55382GD050JU-LW-A-AAN WVGA (800x480) display to the Atmel AT91SAM9263-EK evaluation board, running uC/OS2.

I took the QVGA display off the eval board and added the WVGA display, set the front porch, back porch, and pulse width parameters per the Optrex data sheet, and got it to work, sort of. "Sort of" means that we can't get it to display on the full 800-pixel width; it only displays on 480 wide by 480 high, and also we can't get the vertical sync to run at the right frequency.

I have found what I believe is a bug in the Micrium BSP for that board. In the definition of the BSP_LCD_PARAM struct in bsp_lcd.h, and in its initialization in LCDConf.h, the horizontal and vertical parameters are reversed from one another. However, if I change them so they match, the display shows garbage.

Also, the vertical sync (which is not used on the display that comes with the AT91SAM9263-EK) is supposed to run at 60 Hz per the display data sheet, and there is a
"#define AT91SAM9263_EK_QVGA_CFG_FRAME_RATE_HZ 60" in LCDConf.h that is supposed to set that frame rate. However, the vertical sync cannot (so far) be made to work at 60 Hz or anywhere near it.

On the AT91SAM9263, LCDTIM1 is used as the vertical sync generator and LCDTIM2 is used as the horizontal sync generator for the LCD. Each takes a front porch, back porch, and pulse width and uses them to generate the sync pulse.

When I load LCDTIM1 with the values the BSP says to use for 60 frames per second, I get an output of 51 Hz... not really close, but probably close enough, and I can tweak things to raise it if I need to. However, after I do that, I load LCDTIM2 with porch and width data to generate the horizontal sync... and LCDTIM1 (the VERTICAL sync generator) goes from 51 Hz to 13 Hz.

I would think that LCDTIM1 and LCDTIM2 should be independent of one another and can't find anything in the data sheet that says otherwise. Why, then, does loading LCDTIM2 so radically change the output of LCDTIM1?

Have any of you had success adapting a WVGA LCD (Optrex or other) to the AT91SAM9263-EK eval board running uC/OS2?

Thanks...

Return to “- µC/OS-II - Real-Time Kernel”

Who is online

Users browsing this forum: No registered users and 1 guest