ATSHA204A data write error ,why?

Discussion about SAM7 Series and ARM7TDMI based products.

Moderator: nferre

zhuang
Posts: 1
Joined: Fri Jul 31, 2015 4:47 am

ATSHA204A data write error ,why?

Fri Jul 31, 2015 5:33 am

Hi, all
Now I want to use ATSHA204A chip,
I do not use the burning software,I use write command to carry configuration config and data area,Now config and data area has been configured successfully.but write data area slot data is not correct。 :cry: :cry:
For example,I sent the following instructions for configuration:
{0x0b,0x12,0x00,0x05,0x00,0x00,0x00,0x00,0x00,crc[0],crc[1]};
//configuration slot 0 and slot 1 read and write permissions
{0x07,0x17,0x80,0x00,0x00,crc[0],crc[1]};
//lock config area
{0x27,0x12,0x82,0x00,0x00,[slot 0 data(32 byte)]crc[0],crc[1]};
//write slot 0 data (32 byte)
{0x07,0x17,0x81,0x00,0x00,crc[0],crc[1]};
//lock data area
QUESTION:
I read the solt 0 data is not the data I write :? :?
jharley
Posts: 238
Joined: Thu Dec 06, 2012 6:40 am

Re: ATSHA204A data write error ,why?

Fri Jul 31, 2015 1:15 pm

Hello,
I haven't used this device.

However, according to the datasheet (5.2 I/O Flags), it looks like you are not sending the proper command flag (ie. {0x77,0x0b,0x12,0x00,0x05,0x00,0x00,0x00,0x00,0x00,crc[0],crc[1]};

This assumes that you are using the single wire interface. If using the I2C interface see the datasheet.

Regards

Return to “SAM7 ARM7TDMI MCU”

Who is online

Users browsing this forum: No registered users and 3 guests