Corrupted NAND Flash

This forum is for users of Atmel's SAM Series and who are interested in using WinCE OS.

Moderator: nferre

engst03
Posts: 6
Joined: Mon Feb 08, 2010 5:21 pm

Corrupted NAND Flash

Tue Feb 09, 2010 4:19 pm

Yesterday I posted here (dont know why the post vanished) that I am not able to do the recovery procedure on a brand new board (M10).


Now I found out that on my brand new board the NAND Flash is corrupted.

-I- Found 5 Bad Blocks :
Block 366
Block 1003
Block 1173
Block 1216
Block 1703



My original post yesterday was:

: I just tried the demo recovery as explained in the documentation. Unfortunatly it hangs. The logfile shows: -I- Waiting ... -I- TCL platform : Windows NT -I- SAM-BA 2.9 on : windows -I- Retrieved arguments from command line : -I- argv 0 : \usb\ARM0 -I- argv 1 : AT91SAM9M10-EK -I- argv 2 : demo-at91sam9m10ekes.tcl -I- Connection : \usb\ARM0 (target(comType) = 0) -I- Board : at91sam9m10-ek -I- Traces Level : 4 -I- target(handle) : 25936184 Read device Chip ID at 0xfffff240 --- get 0x00000000 Read device Chip ID at 0xffffee40 --- get 0x819b05a2 -I- Found processor : at91sam9m10 (Chip ID : 0x819b05a2) -I- External RAM Settings : extRamVdd=0 extRamType=1 extRamDataBusWidth=16 extDDRamModel=0 -I- Loading applet isp-extram-at91sam9m10.bin at address 0x308000 -I- Memory Size : 0x8000000 bytes -I- Buffer address : 0x3095A4 -I- Buffer size: 0x0 bytes -I- Applet initialization done -I- External RAM initialized -I- Command line mode : Execute script file : demo-at91sam9m10ekes.tcl -I- === Initialize the NAND access === -I- NANDFLASH::Init (trace level : 4) -I- Loading applet isp-nandflash-at91sam9m10.bin at address 0x70000000 -I- Memory Size : 0x10000000 bytes -I- Buffer address : 0x70003BE8 -I- Buffer size: 0x20000 bytes -I- Applet initialization done -I- === Erase all the NAND flash blocs and test the erasing === -I- GENERIC::EraseAll -I- === Load the bootstrap: nandflash_at91sam9-ek in the first sector === GENERIC::SendFile nandflash_at91sam9m10ekes.bin at address 0x0 -I- File size : 0x13EC byte(s) -I- Writing: 0x13EC bytes at 0x0 (buffer addr : 0x70003BE8) and here it just stays hanging.
roman3017
Posts: 2
Joined: Mon Mar 15, 2010 6:51 pm

Re: Corrupted NAND Flash

Mon Mar 15, 2010 7:00 pm

Have you resolved this problem? I am experiencing exactly the same.
roman3017
Posts: 2
Joined: Mon Mar 15, 2010 6:51 pm

Re: Corrupted NAND Flash

Tue Mar 16, 2010 4:32 pm

I have got help from Atmel. It turned out that the problem was with the patch for SAM-BA. I have a chip SAM9G45 ES2 and aparently one should not apply AT91-ISP.zip (Windows XP - v1.13 current release - patch) for this chip. After reinstalling SAM-BA, the problem went away.

Return to “WinCE”

Who is online

Users browsing this forum: No registered users and 1 guest