Page 1 of 1

can Linux-2.4.27-VRS1 works with gcc 3.4?

Posted: Wed Apr 06, 2005 12:57 am
by atemken
I will use RVDS 2.2, but RVDS 2.2 only interworks with gcc 3.4.
can Linux-2.4.27-VRS1 works with gcc 3.4?
what eles do I need?

Posted: Tue Apr 12, 2005 7:28 am
by ulf
I think the recommended version to compile Linux 2.4.27-vrs1
is gcc-2.95.3

can Linux-2.4.27-VRS1 works with gcc 3.4?

Posted: Tue Jul 05, 2005 10:54 am
by nahas.sylvain
The answer is Linux-2.4.27-VRS1 can not compile with GCC version 3.4 and older.

The reason is GCC 2.4 has changed its policy about inlined functions : functions declared as inlined but without actual body generate compile time errors. And such declarations are to be found in the headers of the kernel in some place.
You may find a patch around that correct the kernel source code.

Anyway, Linux-2.4.27-VRS1 compiles very well with GCC 3.3.6