Page 1 of 1

9g20ek and buildroot-2019.02.4

Posted: Sun Jul 21, 2019 8:49 pm
by zibi79
I'm trying to build kernel 4.4.14 and rootfs with gcc 4.9.3. for at91sam9g20-ek board
First I started with vanila system. Everything in default
make ARCH=arm at91sam9g20dfc_defconfig && make ARCH=arm
Using Jlink I can upload bootstrap, u-boot, dtb and rootfs but the system stops on "Starting kernel".
What i'm doing wrong.
The demo from linux4sam is working fine on this board so I'm assuming it's me not the hardware
"linux4sam-buildroot-at91sam9g20ek-4.2"
The board model is MDK9g20 EK
Thanks for any help.

Re: 9g20ek and buildroot-2019.02.4

Posted: Tue Jul 23, 2019 1:15 am
by blue_z
zibi79 wrote: I'm trying to build kernel 4.4.14 and rootfs with gcc 4.9.3. for at91sam9g20-ek board
First I started with vanila system. Everything in default
...
The board model is MDK9g20 EK
Since you do not actually have an Atmel board, the "default" configuration may not be appropriate.

zibi79 wrote: make ARCH=arm at91sam9g20dfc_defconfig && make ARCH=arm
Buildroot does not require the ARCH environment variable.
That command sequence would not build Linux "kernel 4.4.14" nor "gcc 4.9.3" using the "default" configuration as you claimed.

zibi79 wrote: Using Jlink I can upload bootstrap, u-boot, dtb and rootfs but the system stops on "Starting kernel".
That's not descriptive enough or as informative as you assume.
Rather than what you "can" do, exactly what did you transfer to the target board?
You didn't mention any kernel image.
It may not be relevant at this stage, what what kind of rootfs image?
What nonvolatile memory did you write to and where?

A complete boot log and listing of the U-Boot environment is appropriate for this type of problem.

Regards