Kernel Boot boot then long delay and "crng init done"

This forum is for users of Microchip MPUs and who are interested in using Linux OS.

Moderator: nferre

zdhovey2000
Posts: 17
Joined: Fri Oct 13, 2017 9:52 pm

Kernel Boot boot then long delay and "crng init done"

Sat Mar 31, 2018 6:13 pm

MCU: sama5d4_xplained
Board: Xplained (also occurs on 3rd party board)
Kernel: 4.9.36 (from github: linux4wilc/linux-at91)
Cross_comp: Linaro gcc version 5.4.0
rootfs: Latest from buildroot4wilc

At the completion of bootup, as far as the console UI is concerned, I get "crng init done" that occurs about 10 seconds or so after the login prompt. I have tracked the message origin down to "random.c" in the kernel, but nothing obvious stands out as to the cause. I've seen other systems do this, but not really any solutions.

Has anyone come across this or know what could be causing it?
kengineer
Posts: 15
Joined: Tue Oct 31, 2017 3:08 pm

Re: Kernel Boot boot then long delay and "crng init done"

Thu Apr 05, 2018 5:42 am

Yes I see the same thing on a D2 SIP board. I haven't bothered to try and figure out what it is because it doesn't cause any problems. Are you seeing some type of issue?
zdhovey2000
Posts: 17
Joined: Fri Oct 13, 2017 9:52 pm

Re: Kernel Boot boot then long delay and "crng init done"

Thu Apr 12, 2018 10:36 am

Yes, but I'm not experiencing any issue directly related to it except for it interfering with my console work after booting. It appears on both my custom board and the sama5d4-xplained eval board but didn't always. I think it started after happening after I started compiling the kernel using hard float or once I began using my own rootfs. I can't be sure which.

Return to “LINUX”

Who is online

Users browsing this forum: Baidu [Spider] and 2 guests